cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

QuattroTom
Journeyman III

7900 XTX crashes in PUBG

Hey everyone,

I built a new PC with a 7900 XTX Sapphire Nitro  and have been having issues while gaming. Specifically, I've been experiencing crashes while playing PUBG. The game crashes about 5 minutes in, and I receive an error message: Log 1 was 0x887A0006 ('HUNG'). In the event viewer, I can see that the display driver amdwddmg has stopped responding and has successfully recovered.

I tried doing a DDU and reinstalling my drivers, but the same issue occurred. I also switched to DX12, which seemed to work for about 30 minutes, but then I received another crash with the UE4CC-Windows-1AE0F1A446EAA6C5D7DFEEADF782BE54_0000 error.

Sometimes Discord crashes too, even when I try gaming with and without Discord. I turned off the overlay, but the problem still persists.

I'm running Windows 11 Pro, and any help or advice would be greatly appreciated.

Thank you.

24 Replies
th3count
Adept I

I am having the same issues 2 different builds.

Asus X670E-A and X670E-F,

7950 X3D

saphire nitro+ 7900XTX and Saphire pulse 7900xtx

mrstonecold
Journeyman III

Same issue. Latest drivers , Sapphire nitro+ 7900XTX

I'm not sure if this is related but it seems to be games that use battle eye anti cheat. 

I can almost replicate the issue with PUBG, dayz and the cycle frontier.

Warzone , Fortnite run fine no crashing. 

 

0 Likes
th3count
Adept I

Warcraft, Black Desert, Pubg are doing it for me.
Warzone is fine

 

I will let you know if I find anything out.

0 Likes
stan
Elite

Do you  enable XMP or EXPO?

Try to disable it and then test.

 

 

0 Likes
th3count
Adept I

I have enabled and disabled EXPO. this is also happening between 2 builds.

Had some progress tonight. Limited the power on the card to -10% and underclocked set max frequency to 2600mhz on the core. Been stable in pubg all night. Gonna try releasing the power and increasing the clocks tomorrow.

 

I noticed I was getting just shy of 3200mhz boost clock in hwmonitor with stock settings.

I've been fighting with PUBG for days... no games I play have crashed, but PUBG i legit could not get through a single game. Crashed every single game, normally within the first 5 minutes. Tried all the fixes I could find.. 

Just did what you said and reduced max frequency to 2600 and did the -10% power and low and behold I got through a game! Hoping this solves it and i just didnt get lucky 1 game

0 Likes

Since I don't know much about these kinds of things, could please tell me specifically how to reduce frequency to 2600 and reduce power 10%. I'd to try this. I am getting timeouts or error messages in just a minutes or two and have tried everything else I've seen written up.

0 Likes

Looks PUBG has problem with high FPS over 200. One more quick advice = try to turn on VSYNC and you don't have to underclock your graphic card. Then please let us know if the game is stable with VSYNC or not. Thank you!

0 Likes

It works for me. I had my 7900XTX set to 96% max frequency, 98% voltage, and -2% power limit. It's well enough for me and I didn't notice any substantial performance loss. Plus I get a bonus wattage decrease about 100W! (Before it was ~380-400W, now it's 280~330W)

0 Likes

I can also confirm boost clocks boosting up much higher than a set max clock. It should not be boosting up higher than a set max but it is. I also saw my 7900xtx boost up to 3200 all while max boost was set down under 2900.

0 Likes
QuattroTom
Journeyman III

Unfortunately time was encroaching on my 14 day return window so I had to send it back. Ordered a 4090 not the best experience with my first AMD GPU

th3count
Adept I

Gonna RMA my card shouldn't have to underclock the card for stablility.

0 Likes
yankee0903
Adept I

Hi all,

I had the same issue with PUBG and 7900XTX and I think I found the fix.

I updated all my drivers via SDIO https://www.glenn.delahoy.com/snappy-driver-installer-origin/ and PUBG stopped crashing. I played whole week without single crash.

If possible please test in on your side and let me know.

Thank you!

0 Likes

Hello. Please try the 23.30.13 driver on Avatar. It helped me! They play all games at 4k and luxury performance now.

0 Likes
m1nicrusherr
Adept I

Same thing with PUBG happening to me...

GPU: RX 7900 XTX NITRO+ Vapor-X
CPU: 7950X3D
MB: ROG CROSSHAIR X670E GENE
850W PSU

I currently have EXPO on. Driver version 24.2.1

Yeah I've been having the issue for about a year now. It's gotten better but it seems to be coming back.

Amd seems to be fixing the driver timeout issue one game at a time if you read the last few driver updates notes. You would think they could find an underlining issue here. Fixing 1-2 games by driver update isn't good enough. 

0 Likes

If anyone's wondering how I resolve the issue is that as th3count mentioned above, I underclocked my GPU just a slight a bit and that's enough to keep the game running without any problems.

I had my 7900XTX set to 96% max frequency, 98% voltage, and -2% power limit. It's well enough for me and I didn't notice any substantial performance loss. Plus I get a bonus wattage decrease about 100W! (Before it was ~380-400W, now it's 280~330W).

davidavid
Journeyman III

The 7900 XTX graphics card occasionally crashes in PUBG, affecting gameplay experience. Users report instances of sudden freezes or black screens during intense gaming sessions, leading to frustration and disruption. Despite its powerful performance in other games, the 7900 XTX seems to struggle with stability issues specifically in PUBG, prompting players to seek solutions or alternative hardware.

 
 
 
 
 
 
 
 
0 Likes
yankee0903
Adept I

Try switching to DX11 and turn VSYNC ON. Then please let us know the result. Thank you.

0 Likes
yankee0903
Adept I

Hi everyone, I tried another fix that also seems to be working. I lowered GPU performance in AMD Adrenaline software (Performance -> Tuning -> GPU section).

Please see attached screenshot.

yankee0903_0-1710932206827.jpeg

 

cilantro
Journeyman III

Hello everyone, I'm also struggling with 7900XTX driver timeouts when playing PUBG. The game crashes every time I play it within about 2 minutes of round start in deathmatch and several times during a team battle royale. The last driver version that worked without problems was 23.12.1, and every driver version since then has had this issue on my computer. I cannot go back to 23.12.1 as my PCVR setup no longer works with that.

For the current driver 24.3.1. disabling SAM and/or EXPO did not solve the problem. Enabling VSYNC and DirectX11 in game settings did not help. Using AMD Adrenaline program I also tried limiting max GPU frequency for PUBG to GPU boost frequency 96%, voltage to 98% and power to -2%, as suggested above, but it did not help either. I reduced max frequency further down to GPU boost frequency 2497 MHz (equivalent to 82%) to no avail. Reseating GPU also did not work.

CPU: 7700x
GPU: Gigabyte 7900xtx
PSU: 850 W Seagate Gold
MB: Gigabyte X670 Gaming X AX
32 GB DDR5

Any help is appreciated!

0 Likes

In Adrenaline software go to Gaming select your Game Pubg  scroll down to Radeon chill 

set min Frames to 75 and max frames to what ever your monitor refresh rate is.

Also try  I think pubg 

can play in dx11 and dx12 ,, let me know if this help.

 

7900 XTX MERC 310

7800X3D

0 Likes

undervolted  to 1125 pubg g stopped crashing.

7900 XTX MERC 310

7800X3D

0 Likes

Thanks for the tips! Undervolting did not help in my case, but it lead me in the right direction, as it was reducing the GPU max frequency that stopped crashing for me. Weirdly, I tried it earlier to no avail as I mentioned, but this time I had made a clean install for PUBG as suggested here (resets all game settings) and I updated AMD chipset drivers to 6.03.19.217, and then the GPU frequency limiting solved the problem. Maybe the clean install of PUBG was unnecessary, but it's hard to say.

 

If it helps others, my current settings in AMD Adrenaline are Max Frequency (under GPU tuning, Advanced Control slider enabled) 2523 MHz and in PUBG I use DirectX11. No need for VSYNC or limiting max frame rates in my case it seems.

0 Likes