cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

play3r1
Journeyman III

5600G display artifacts

Recently built a new pc (late 2021) and 5600G suddenly showing display artifacts. Tried changing HDMI cables, didn’t work. Updated bios to 2803, didn’t work. Updated drivers from 22.3.1 to 22.5.1, worked for a day but continued the day after. Now my monitor shows “No Signal”. What should I do now?

Specs:

5600G (Not overclocked)

AMD Stock Cooler

ASUS Prime B550M-A AC (BIOS Version 2803)

TEAMFORCE 3200MHZ Ram (D.O.C.P Enabled)

 

Monitor is a Acer SA320

0 Likes
5 Replies
sdancer
Adept II

Try a different monitor? A TV will do in a pich just for testing.

0 Likes

I agree.  The next step is to try another monitor.  Ask a friend if you can borrow one for a short time if you don't have a spare from another computer.

As Albert Einstein said, "I could have done so much more with a Big Al's Computer!".
0 Likes

I did that and worked. I replugged the pc back to the original monitor, booted it up, ran a game until it randomly blacked screen. What could be happening? 

0 Likes

The original monitor is failing.  You need a new one.  I would not attempt to fix a bad monitor.  They are difficult to disassemble and it's probably one of the chips inside that's going bad.

As Albert Einstein said, "I could have done so much more with a Big Al's Computer!".
0 Likes

If the monitor has another input, you could try that. I had an HDMI input go back after a week, and that monitor is happily working with the DVI input since.

0 Likes