Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

(18.2.2) Has stopped my USB ports from working, and there is no display to bios.

System Specs
Radeon Sapphire rx480 (8gb)

Windows 10

Radeon Adrenaline Edition 18.2.2
Samsung Curved Monitor 27" 1920x1080 @72hz HDMI

MSI 970a SLI Krait Edition

Radeon fx6350 unlocked black edition

Corsair CX600 bronze

HyperX 4x4 (16gb) ddr3

Recently I had heard about the new Adrenaline driver update and was pretty stoked, since it was an overall booster on the games I love to play. I started updating my drivers and once it reached 100% my USB's stopped working. At the time, I had thought that my PC had froze, so I forcefully shut it off via power button(I'm guessing this is where I went wrong). When I turned it back on, it booted up to the Windows log in and none of my USB ports are working. I thought I should boot up my bios to maybe revert the failed update, and when I try to enter bios now, there is no display... Not sure if there is a quick fix for this or if I just screwed up my PC! Please help!


4 Replies
Journeyman III

Also a quick note! I've already tried resetting cmos, the problem is still persisting!


This has happens to me in the past. Long time ago. Do you have a wireless keyboard and mouse?

1. Pull out power cable from your PSU.

2. Press start button on PC a few times.

3. Take out the battery from your motherboard and wait at least 10 min.

4. Do the steps in reverse and try again.

5. IF you have a wireless keyboard try with a ordinary one.


I have  a mechanical wired keyboard, I've tried resetting cmos a few times now with draining power with start button each time. I was able to get a hold of a friends gtx1060 and plug it in. It gives me a display and I was able to use usb ports, so something is telling me that the update may have messed my card up. I've ran ddu and got rid of all existing amd drivers, and now when I plug my card back in there is no display at all. I would try to boot into safe mode to install clean drivers but I can't because there is no display to the card, I can't get into bios with it either. BUT.. my USB ports seem to be back online! So that's progress!


This can happen sometimes if you use the AMD cleaning tool on a AMD processor. Download and install the chipset drivers from the motherboard manufacturers support site. These will include the USB drivers.