Showing results for 
Search instead for 
Did you mean: 

Full Spectrum Rendering in Radeon ProRender for Blender

Full Spectrum Rendering in Radeon ProRender for Blender

Today, we are providing a beta preview of Radeon ProRender with Full Spectrum Rendering in our Blender 2.80 addon.  This gives artists a viewport that can be scaled from super-fast rasterized to fully ray traced, all with physically accurate materials and lighting.  You can download the add-on from Here.

What is Full Spectrum Rendering?

In essence, Full Spectrum Rendering is an extension of Radeon ProRender beyond "just" a path traced renderer using OpenCL.  We use the same Radeon ProRender SDK, but have a different rendering backend for Full Spectrum Rendering. This new rendering backend uses rasterization to render the scene like many game engines or the EEVEE viewport renderer in Blender.  However, it uses Vulkan for faster rendering, and then can add ray traced effects such as reflection, refraction, and ambient occlusion. These effects are achieved using compute shaders and smart denoising. The end effect of the renderer is to harness all the power of the GPU, including taking advantage of GPU ray tracing acceleration where available.  Dialing up or down these effects is what allows Full Spectrum Rendering to scale for speed and quality.

Full Spectrum Rendering.png

The other great part here is for developers.  Minimal changes to the Blender plug-in were made to take advantage of this.  And using the universal Radeon ProRender SDK allows the developer and user to change the quality and speed of rendering in only a few lines of code.

Why do I need Full Spectrum Rendering?

There are two huge benefits for artists with this implementation of Radeon ProRender: it is an all-in-one solution, and it helps to fill a wide gap between OpenGL viewports (such as EEVEE) and full path-tracers (like Cycles).  Most of these benefits are realized in the viewport, for lookdev: setting up scenes, and changing lighting, shaders, etc. Now users can get a more interactive experience like EEVEE with more physically correct soft shadows and reflections and refractions.  Furthermore, these are done without the user having to set up light probes or do any other manual tasks. Finally, the quality/speed settings can be changed for more interactive or physically correct lighting and shading based on the user's needs.


How to use it.

For now, we only support Windows 10 with Full Spectrum Rendering (Linux is supported in the SDK).  Download and install the add-on, and select Radeon ProRender as your default renderer in Blender. Switch your viewport to rendered mode, and the rendering will start.  Try the different rendering modes (low, medium, high, full) and see the lighting differences as well as interactivity.

For best results, use Blender's Principled material on your models. A few interesting things to try are:

  • Interacting with the scene, moving, scaling objects around
  • Changing shaders
  • Changing lighting
  • Changing the RPR quality settings and observing differences in interactivity and in lighting quality.

Thanks for trying it out, and as this is a new product, we look forward to your feedback!

Release notes:
2.0.132 9/23/19

  • Glass shader uses reflection + refraction (previously used just refraction)
  • Fixed issue with material previews being too bright
  • Denoiser works in viewport renders
  • IES profiles can be added to point lights, also fixed an issue if they were rotated 90 degrees
  • Lookdev viewport mode is supported
  • Fix issue with outline around shadow catcher objects
  • Removed "mesh" type area light.  Use objects with emissive material instead.
  • Fixed issue with packed images not exporting correctly
  • Add button in material properties to "upgrade" Principled Shader to Uber
  • Uber shader in node graph uses a dropdown menu to enable layers
  • Add Diffuse Albedo AOV to UI
  • Add support for a reflection catcher (next to the shadow catcher in the UI)
  • Support Second UV set.  Select the second UV to export in the mesh properties
  • Change Anisotropy Rotation to match Cycles
  • Fixed .rpr file export
  • Fixed issue with Displacement shader if normal was not connected.
  • Expose Anti-Aliasing filter settings in UI
  • Fixed an issue where viewport rendering could crash in Linux
  • Lights use the built in blender intensity when in "default" power units.  Otherwise use a separate power level.  This better matches Blender.
  • Added Full Spectrum viewport modes (windows only).  These can be selected in the "RPR" menu in the viewport.  Lower quality gives better interactivity.

2.0.150 10/11/2019

  • Fixed a memory leak when rendering a memory leak with the ML Denoiser
  • Displacement now matches the Cycles method.  Set the method in the material properties to bump or displacement (or both).  Note:  If displacement is jaggy, increase the subdivision of the object in modifiers
  • Roughness of Glossy, Glass nodes matches better (cycles squares them)
  • Add a layered texture and shader node for doing complex material or texture layering
  • Scenes with many instances clean up faster after rendering
  • HSV node is improved and faster
  • Add compression settings and single file option to RPR export
  • Viewport rendering no longer freezes blender UI when starting by exporting in a separate thread
  • ML Denoiser is improved
  • Fireflies when using an emissive material with high values is improved
  • Shading artifacts inside shadow of lights are improved
  • An issue with curves on macOS is improved
  • Passthrough shaders now show up in the Emission AOV
  • Windows installer allows installing if only CPU is available for rendering
  • Installer allows installing directly to Blender 2.81

2.0.153 10/25/2019

  • A config JSON file is exported with .rpr file to help rendering with RPRSRender64.exe
  • Support collection settings for indirect only visibility
  •  CPU is disabled for hybrid
  • Support for meshes with PrincipledVolume Shader attached to render as Volumes.  Use this to create a fog box for example.

2.0.162 11/08/2019

  • Add setting for Transparent Background in render settings.  (Under Film section)
  • Denoiser is available for hybrid (except ML denoiser)
  • Fixed error when using "Halo" type particles
  • Updated to support Blender 2.81 Mapping node
  • Add a button to create an environment Fog in world settings
  • Fixed an error when enabling denoiser while viewport is running.
  • Enabled Hybrid modes for Linux
  • Added an option to override materials for a view layer
  • Fixed a few hybrid mode issues:
    • Fixed a bug when changing viewport quality from high to low while rendering could produce crash
    • Made objects with volume shaders transparent instead of pink
    • Fixed warnings with emissive or passthrough materials
    • Disabled tiled rendering for hybrid
    • CPU is disabled for hybrid
  • Updated ML denoiser.  Potentially fixed issues on macOS (please test)
  • Selected final render devices are added to config json when exporting .rpr files
  • Improved RPR Principled shader to be closer to Cycles
    • Emission amount is tweaked
    • Diffuse weight with semi-transparent objects is better
    • Specular input only affects non-metallic

Please download from Here


I'm still a bit new to rendering in Blender, but the performance I am seeing can't be right.  I'm using Blender 2.80 stable on Windows 10 1903 with AMD Adrenalin 19.9.2 on a dual Xeon 8160 system with 32GB RAM and a Radeon VII.  Using the 2.0.133 hybrid plug in from this article I tried the BMW (bmw27_gpu) demo file from the Blender website.  Using Cycles and a tile size of 16x16 I can CPU render in about 1m30s.  Cycles with GPU only (256x256 tiles) I get 1m19s.  When using the ProRender plug in it was only 30% complete after 23 minutes.  Even on Low, the viewport is essentially unresponsive.  The only console error I see is, "WARNING rpr.Engine [11196]:  AOV 'IndexOB' is not found in aovs_info"

Any suggestions on what might be going on or how to tune to get performance on par with/better than Cycles?

the only big problem (in my opinion) is when you turn it on with it set to low,medium or high, every thing just appears in a grey silhouette, when you turn to full everything works fine.

tested with a Radeon rx 460

What hardware do you have checked on in the render?  Also we JUST fixed an issue with the bmw scene and the displacement/bump in there screwing things up.  

Hmmmm Can you check the system console for an error.

(removed old log to make the post clear)

Ok we're checking on it.  At this time that card might not work though sorry for the confusion!  We'll post an update

ok, thanks.

Hi there,

Last version (2.0.132) is causing the whole Blender UI to be extremely sluggish even for trivial scenes (something that was not happening with the previous version).

Furthermore, the plugin doesn't activate unless llvm is installed in the system.

This is on a mac (10.14.6) / Blender 2.80 / Radeon pro 580.

Is there a minimum hardware or driver requirement? I'm getting the same error as gabrielgo when switching to Vulkan rendering modes on rx470 and 19.6.3 drivers.

Also ML denoising is really buggy, most of the time it makes render result completely black, and if it works then whole blender UI becomes very slow (5-10 seconds to register a click).

Thanks for the new version of RPR.

To me it seems the adaptive sampling really does a great job! Or is it better light solvers or something like that or both? Anyway - in my case i can deal with 2048 samples in a scene, that needed 8000 or so before. The ML denoiser seems to be trained better as well. 

Full spectrum rendering works for me in simple scenes - not yet in bigger ones (with RPR and Cycles nodes etc....)

I think a big step would be better object syncing times. In a scene with 158 objects export time takes 1:12 minutes, while rendering 1000 samples takes just the same time afterwards.

Improving this would be great especially for switching viewport to 'rendered' for a smooth workflow.



2.0.134 still gives me the same Errors as gabrielgo is experiencing. Hardware RX 480 8GB / RX 580 8 GB. Normal Pathtracing works - switching to Vulcan Mode gives: 

2019-10-11 18:37:57,741 INFO rpr.core [14324]: Registering plugin with: hybrid_path=C:\Users\meckardt\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\rprblender\Hybrid.dll, cache_path=C:\Users\meckardt\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\rprblender\.hybrid_cache\0x103403
2019-10-11 18:37:57,825 INFO rpr.core [14324]: Plugin is registered: plugins=[1], gpu_devices=[{'flag': 1, 'name': 'Radeon (TM) RX 480 Graphics'}]
2019-10-11 18:37:57,881 INFO rpr.material_library [14324]: Material library located at C:\ProgramData\RadeonProRender\MaterialLibrary\Xml
Traceback (most recent call last):
File "C:\Users\meckardt\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\rprblender\", line 89, in view_update
self.engine.sync(context, depsgraph)
File "C:\Users\meckardt\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\rprblender\engine\", line 12, in sync
super().sync(context, depsgraph)
File "C:\Users\meckardt\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\rprblender\engine\", line 286, in sync
File "C:\Users\meckardt\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\rprblender\properties\", line 399, in init_rpr_context
rpr_context.init(context_flags, context_props)
File "C:\Users\meckardt\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\rprblender\engine\", line 39, in init
super().init(context_flags, context_props)
File "C:\Users\meckardt\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\rprblender\engine\", line 65, in init
self.context = self._Context(context_flags, context_props)
File "C:\Users\meckardt\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\rprblender\", line 338, in __init__
File "C:\Users\meckardt\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\rprblender\", line 66, in wrapped
raise CoreError(status, f.__name__, argv, module_name)
pyrpr.CoreError: RPR call CreateContext(1061891, [1], 1, 1, <cdata 'void *[]' owning 8 bytes>, b'C:\\Users\\meckardt\\AppData\\Roaming\\Blender Foundation\\Blender\\2.80\\scripts\\addons\\rprblender\\.hybrid_cache\\0x103403', <pyhybrid.Context object at 0x000002163BA66C50>) returned error code <-23> with error message: ''

location: <unknown location>:-1

location: <unknown location>:-1
Traceback (most recent call last):
File "C:\Users\meckardt\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\rprblender\", line 94, in view_draw
File "C:\Users\meckardt\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\rprblender\engine\", line 493, in draw
AttributeError: 'NoneType' object has no attribute 'camera'

location: <unknown location>:-1

location: <unknown location>:-1

Also i have to taskkill Blender upon closing it. Something is fishy with this Version. Looking forward to the Feature tho.

Sure enough I was hoping this update might make this Full Spectrum viewport modes work a little smoother since the first release just crawled and crashed constantly, but wouldn't you know this one wont even install,  here's what I get, after STILL asking for the Blender executable location twice.......msiexec_aUekYpLBht.png

We don't exactly test with blender nightly builds.  Only the official releases.  Sorry.  We'll start testing with 2.81 soon.

Thank you for your fast response,  I thought my Blender version could be the issue,  but I really use a a few features of 2.81 more than I would use the full spectrum options in ProRender, but I do look forward to using it when I can, thanks again!

Thank you for your already fantastic work, guys!

Do you have a rough idea when the hybrid rendering feature will hit the Mac version? Tbh, that would be exactly the feature I was waiting for to replace EEVEE/Cycles in my blender workflow on mac.   

Today I made another attempt to try to use an updated version of ProRender again (2.0.153), because I really do prefer to keep the software I use as up to date as possible, and certainly when the developer keeps adding new features.  Since for some reason these last few newer versions of ProRender refuse to install into Blender 2.81, (even though the older RPR versions will install)  I used my 2.80 Blender copy which I don't typically use, but just wanted to see how this RPR update has improved.  Well other than the fact that it did actually install, it seems to be just as unusable and bad as the first version of this "Full Spectrum Rendering" version I tried was.  With nothing but the default cube in an empty scene, with sun & sky world, first three times I try any setting but "low", Blender just freezes up and needs to be forced closed.  Then if it doesn't just freeze up it crashes straight to the desktop, with absolutely no error or anything, 2 times it actually rendered the scene on "high" but the instant I try to rotate the view, or anything else, it's crash right to the desktop again.  I really hope this full spectrum aspect isn't going to become your major focus with regards to the future updates and improvements, because it doesn't really seem to be all that necessary , and at least for me has pretty much ruined what has been, until recently, a rather dependable, predictable, and plenty fast render engine.  From my point of view I would much rather see improvements in the way nodes and shader settings are compatible between Eevee and prorender (Cycles also), I don't mind just using Eevee when I want to use an openGL renderer for some reason, but I will ALWAYS prefer a great PBR renderer for any final renders, and honestly I don't run into many instances where ProRender has been to "slow" for my needs, in regards to viewport rendering, although a render engine that crashes, freezes and gives unpredictable results is does present a real problem to me. 

In case it is relevant, my system specs:

Win 10 1903

ASUS B450-f

Ryzen 5 3600

G.Skill RipjawzV 3200mhz DDR4

Samsung EVO850 SSD


Hi   bsavery‌ 2.0.153 seems really better and faster to me, almost no errors and i can preview a scene with 2.3+ Million vert on both lookdev and render mode without crashing, but i have a question, quality menu for hybrid in lookdev doesn't appear anymore, is it related for Rx 460 not being supported yet? 
2019-10-31 (2).jpg

Hi gabrielgo,  are you sure that the download you got from AMD actually is the 2.0.153 version?   Because the AMD ProRender website has had a history of not having the links correct or updated quickly.   If I know there is an update, or just want to check, I will use Google's "time" filter on there search page and set it to "within last week" or even "24hrs"  and see what the latest results are.   I have had trouble in the past getting the right versions, also I have installed the wrong version by mistake since the .msi files all have very similar naming between versions, and I tend to have a few previous downloded versions still in my downloads folder.  It's worth checking since that RPR menu looks just like the older versikon which I still use since the "Full Spectrum" versions just won't work for me on my system oddly.

Hi jl5086‌, i downloaded from this page, in the link that bsavery posted.
2019-11-01 (3).jpg
i always manually uninstall older versions first before installing a newer one
2019-11-01 (1).jpg

but dont worry i've downloaded wrong versions several times too

It was a just in case suggestion,  I know a number of times there would be a version update to an RPR plugin and the actual link on AMD's ProRender page would still be the old one, and this lasted for quite some time, and I would have to come here and get the link from the forum post, but at least your aware of it and that won't be an issue anyway.  It is unfortunate that I can't use any of the latest updated ProRender versions for some reason, Kind of frustrating considering I am team red all the way, and for some reason upgrading from a 2nd gen Ryzen Zen+ to a 3rd gen Ryzen CPU, and from an RX-580 to an RX5700 XT has made ProRender LESS stable and not even work anymore with the latest update.   On aside note, as much as I love ProRender, I have recently downloaded the most recent release of Luxcore Render, it is also free, and uses OpenCL.  Plus it is one of few renderers who's plugin is integrated as nicely as RPR, it does use it's own node system, with node setup templates, but you can also use Cycles nodes if you choose.  I really like the options it provides for real-time post-processing effects, such as bloom, chromatic aberration, vignetting and a long list real film type simulation, and best of all it all shows up in the viewport renders real-time, without having to use the compositor and apply them to the finished final render.  For a free renderer it is quite impressive, and once you enable the addon it just shows up in the list with cycles and prorender, so it's nice to have another good render option in the list.  Of coarse like all the other renderers, it doesn't work AT ALL with any prorender nodes or materials, so that's a bummer, but not surprising.  If ProRender doesn't ever want to work for me again, than this may have to become my new go to renderer,  since I backed AMD so much even most paid render options are all CUDA/nVidia or CPU based, so I've limited my options.  This time around I actually gave some serious thought to buying an nvidia GPU instead of AMD, but in the end I knew that AMD GPUs have always provided me with what I need, at a much more reasonable cost (so long as the software is cooperating).  I understand the software developers wanting to utilize all the proprietary  nvidia hard/software people payed extra for, but to me it's insulting to not at least support openCL, and that makes me reluctant to invest in any nvidia product, because you don't see AMD deliberately writing software that explicitly doesn't support anything but AMD, just to help the customer justify why their GPU cost so much more money.   Sorry for such a long rant.

It's been driving me crazy not being able to use the latest ProRender, so I gave it another shot and tried to install the latest version again, since the only one that has been stable is the last version before the addition of Full Spectrum Rendering.  This time it didn't go well either,  I use Blender 2.81, but the ProRender installer gives an error with that version, I think because the error (I posted a few posts above) is looking for a file named 2.80 and not 2.81, so this time i even tried installing to a 2.80 stable version, although it does install now, as it did the very first time I tried it, it just won't cooperate with me.  The very first time I render a scene, for instance, a very simple scene, 3 area lights, 1 plane and a clear colored wine glass.  when it compiles the kernels it takes well over a minute, much longer than before, after it begins the viewport render it seems ok, but if I change anything in a material node, i.e. absorption color on the glass, it changes in the node editor, but the render doesn't update the change I made, though I can still orbit around and it still renders, just without the change I made to the material.  At that point if I try to cycle to shaded view, and back to rendered view (to update the material change), occasionally it will work, and the material will now show the changes I made to it, but 9 out of 10 times it crashes as soon as I click on the shaded view button,(but if I haven't adjusted the material, it doesn't crash) I do know from experience that certain things in blender can be unreliable, such as adjusting anything through the F6 panel in the lower left side of the 3d viewport, (not that it is in anyway related, but it's just showing how it's very similarly frustrating, how it can just crash the whole program just by adjusting something in it).   All the vulkan modes seem to work, at least for a few seconds to a few minutes, but it WILL crash if I try to adjust anything or even just orbit around a bit.  When it does crash, it's immediate to desktop, and if I try to reload Blender, 90% of the time it hangs on the gray screen (while the console hangs on something relating to "rpr.cache" or something similar, requiring either multiple tries to get it to load again, or a restart of the computer. Also half the time when RPR causes blender to crash to desktop, while it's actively rendering, it leaves the computer in a really "crippled" state, meaning the mouse cursor will barely respond and hovering over taskbar or icons is the response is severely lagging, and this grows worse by the second if I don't quickly try and get the computer shutdown, so I can restart it, because if I don't It will lock up, and force me to do a hard reset of the entire system.    I know this post doesn't really provide any info to work with, but I just wanted to convey what I experience when attempting to use this.  I posted my system specs in an earlier post above, I don't know what would cause this since it doesn't give me any info when it crashes,  It is very reminiscent of trying to use Blender 2.8 back in 2018 when it was still beta, saving EVERYTHING every 1 minute.  But with these most recent versions of ProRender, for me, sometimes just saving at the wrong time crashes it.    Also note, I do check every single day for display driver updates for my RX5700 XT, in case that may help this.  Thanks.blender_188mcu3Pdf.pngI got this error after on of the few times is didn't just kill blender completely, so I was able to check the console for this.  This was Blender 2.81,  because surprisingly with my 2.80 version, ProRender "Full Spectrum" is even more unstable than with 2.81.  This crash that I got this log from, was simply the default cube with nothing else, no lights and no materials, all I did was try to use the different render modes.    Maybe it gives you some info.

i've tried a render and now i can confirm its extremely lag here too, and about errors i am almost getting none

i am AMD all the way too since it cost much less and do the job for me, but its a fact that nvidia is much more well supported by devs (Cycles for exemple and a lot of games).
but i also think that the development of Radeon Pro Render is going well, because i believe bsavery is the only dev right now.

            Is there any way, or place, to get the current, and previous versions of the ProRender for Blender addon NOT in a windows .msi installer format.  It is extremely inconvenient since I am having trouble using these latest versions of the plugin with my system.  With most every other Blender addon you can simply add the folder containing the plugin into the scripts directory, and replace it with a newer, or older version as needed.   Every time I want to see if a Display driver update has helped or if a new version of ProRender will work,  I have to use the windows add/remove programs, and then go through the whole process of running the installer and telling it which version of blender's .exe to install to, and that's lousy because I use various different versions of blender 2.8, and if I want to "try" prorender in the 2.81 version of blender, which is the version I actually use daily, that means I am forced to uninstall whatever RPR version I have installed in my 2.80 blender, so that I can then re-install the new version I want to try, so that once it is installed I can go into the scripts folder of the Blender 2.80 installation and copy the Prorender addon folder and place it into the scripts folder for the blender 2.81 version that I actually want it to be in (but it refuses to actually install into when using the ".msi installer" because it's only looking for a file with "2.80" in it's name) After all that when it still doesn't run right and crashes my computer I have to go through all these hoops and "uninstall RPR" and then "Re-run the older RPR installer" to get the old version back that runs OK.    I do also try whichever version of ProRender I install on both my 2.81 version, and the 2.80 version of Blender, to make sure it is not just the "unsupported 2.81 version" that is unstable on my system, and so far I have seen the same crashing and has been just as unusable on both versions of blender.  

            I suppose I COULD go through and install RPR, save the addon folder elsewhere, then uninstall it, and repeat with all the versions I have, but it would be nice to not have to do that with each update to ProRender for Blender that comes out.  It would really be helpful to at least give the option for a manual installation of this addon.   Also a place to download previous releases of ProRender would be useful. 

            I downloaded some .blend files from your ProRender for Blender documentation page, and on in particular, the Render_Passes.blend(114mb) Does not render at all with my version of ProRender (2.0.112) on either 2.80 or 2.81 of Blender(it gives no errors,and doesn't crash, it just shows sort of like if you had materials that weren't compatible, it's all dark, and it never shows any info about starting render or compiling kernels,  But on version RPR(2.0.153) it does at least render the image, but crashes if I navigate around or touch anything else.  So because of this I would like to find a slightly earlier version, like maybe 2.0.093, but can't seem to do so anywhere.  I would really like to try and use a version that is as stable as possible and will also at least render a scene built using this renderer.

Install the new version 2.0.162 under Linux with 

Traceback (most recent call last):
File "./", line 129, in install_component
File "./", line 327, in <module>
subprocess.check_output(install_blender_addon_cmd, stderr=subprocess.PIPE)
File "/usr/lib/python3.6/", line 356, in check_output
File "/usr/lib/python3.6/", line 438, in run
output=stdout, stderr=stderr)
subprocess.CalledProcessError: Command '['/home/schulze/Programme/blender-2.8/blender', '--background', '--python', '/home/schulze/.local/share/rprblender/addon/']' died with <Signals.SIGSEGV: 11>.

Installing 'addon to Blender' failed!

Materlial Library ist not installed

I am just wondering why you changed the only download link on this post to a link for RPR 2.0.134, instead of the  newer v2.0 releases?   2.1 is unusable for me now.

Sorry about that.  I meant to link to  If there's an issue with 2.1 please help us debug it. 

Whenever I switch to full render quality this happens , switching to low, medium or high results in this , here is what the scene should look like.

Please attach a scene.  We also update the version on to 2.2.  Check that out too!

I am going to give ver 2.2 a try today, but I do have a small request though,  on the release notes you have had the exact same paragraph stating that you have updated the material library with new materials.  That has been in the release notes ever since the very first version 2.0 release, and I don't think it should really be in there if it really is the same download as with every other release.  I end up re-downloading it every single time because I don't know if maybe this time it REALLY did get updated.  It would be good to know for sure whether I should go through the trouble of downloading it, and installing it, if it's hasn't changed at all.


Sorry.... I actually didn't realize that either.  I'll remind the right person.

Hello, I'm a C4d user. I'm using the built-in prorender. The C4d R21 version is very fast, and the rendering quality is very high, but it seems that it can't support multi-channel very well. Besides, I can't create volume light effect through prorender at present. How can I achieve it? Or does the current version not support volume lighting?

Version history
Revision #:
1 of 1
Last update:
‎09-23-2019 11:14 PM
Updated by: