Showing results for 
Search instead for 
Did you mean: 

AMD Radeon ProRender for Blender 2.80 Beta

AMD Radeon ProRender for Blender 2.80 Beta

Screen Shot 2019-02-15 at 11.32.41 AM.png

We are excited to finally talk publicly about a version of Radeon ProRender that supports Blender 2.80!  Blender 2.80 is has a great deal of interest from users due to its radical changes to the workflow, and we thought it was only appropriate to give the ProRender plugin the same attention.  We have been working hard over the last few months and this is just a preview of what the final product will be.  Expect updates weekly-ish until Blender 2.80 is released and a final plugin ready when Blender is.  Hats off to the Blender Institute for such a game-changing release!

Radeon ProRender is a GPU and CPU rendering engine.  It is built into Maxon's Cinema4D and other software (coming soon).  AMD also provides plugins for various other applications including Blender.  One nice aspect is that is hardware agnostic: any GPU that runs OpenCL should run ProRender.  On macOS in particular it takes advantage of the Metal2 api to run faster, where many renderers do not support GPU raytracing on macOS.  Particularly with Blender 2.80, the built in Cycles renderer no longer runs on GPU's on macOS so hopefully this fills a gap there.

So why have we been quiet and working hard over the last few months?  Since Blender 2.80 changed their API for plugins significantly we had to adapt the plugin to that.  Also we decided to take this opportunity to rewrite the plugin from the ground up for a few reasons.

  • Better integration into Blender and overall user experience.  One ask we heard many times was to support Blender's built in nodes more.  But also that users really appreciated RPR's Uber Node as an "expert mode".  So what we did was try to satisfy all those asks    More on this later
  • Achieve the best stability possible.  The architecture of the old plugin was frankly a bit of a mess that was limiting the stability in some cases.  We took a ground up approach to make it simpler, more stable and maintainable in the code
  • Provide a "Best of both worlds" User rendering experience.  Obviously Blender 2.80 users are excited about EEVEE.  It is a real time rendering engine similar to semi-modern (pre-hardware raytracing) game engines providing a good viewport experience.  However, because it is essentially a game engine, the results with area light shadows, subsurface scattering, GI, etc are less than what users expect with RPR or Cycles.  
    With RPR, and we are working to bridge the gap:  Provide the full path-tracing final renderer and a "fast viewport mode" without the approximations of a game engine so what you get in the viewport is closer to your final render.  The new plugin is rearchitectured to take advantage of this upcoming work.

In particular I will highlight the shader workflow.  Many users are used to and have setups using Blender's built in nodes.  What the RPR plugin does now is let you keep these (some nodes aren't supported yet) and simply hit render, no conversion required.  Particularly we convert the "Principled BSDF" directly to our Uber shader.  For users who want a more "advanced" shader they can convert Principled to Uber.  So keep your Blender Node setups and augment with advanced RPR nodes!  This in particular is an area we would like feedback on and testing.

Screen Shot 2019-02-15 at 11.48.01 AM.png

Like I said, we will be updating weekly-ish with new builds.  Please give them a try and give your feedback, it will only make the final software better for you.  Also if you have programming experience and are willing to help with the plugin code, we would love to hear from you.  

Brian + the whole AMD ProRender Team.

PS!  If you see answers from Bogdan or Mikhail here, please thank them for the hard work they have put in on the plugin!

UPDATE 5/31/2019

In anticipation of Blender 2.80 release in July 2019 we are updating our builds.  Blender has been changing their API so be sure to get a build later than 5/23/2019 (Best to just get the latest build of blender 2.80 Here . 

A bunch of changes have happened since the last beta builds so here are all the changes:


  • The Radeon ProRender for Blender plug-in has been completely rewritten for Blender 2.80. This includes many changes to artists workflows:
    • Blender native shader nodes are supported out of the box. Including the Blender Principled Shader node. Most common nodes are supported, but a few, noted in known issues, are not translatable.
    • Additionally, RPR nodes, particularly the Uber node is provided for a more “expert level” shader setup.
    • Viewport and final rendering are more robust and optimized.
  • AI-Accelerated Denoiser (windows only for now) provides an extra denoiser based on machine learning technology.
  • Adaptive Sampling allows the renderer to focus samples on areas of the render that are higher in noise, while ending early in areas without noise. This allows the artist to raise max samples and get less noise without raising render times as much.
  • Blender hair geometry is supported as well as “Halo” (sphere) particles.
  • A tiled rendering option allows rendering images by tiles, allowing higher resolution renders without using as much VRAM. Additionally, the size and order of tiles can be adjusted.


  • As this is a complete rewrite of the plug-in, many stability bugs are fixed, and changes made.
  • Various fixes to Uber shaders to improve physical correctness. Note geometry using Uber shader may look different but will be more physically correct.
  • Fixed issue with camera inside a refractive/sss/volume object.
  • Fixed issue with anisotropy in Uber producing a checker pattern.
  • Fix for textures with .jpeg extension (.jpg worked fine).
  • Fixed an issue of adaptive subdivision with displacement map spinning the CPU at 100% before render starts.
  • Fix light motion blur on CPU.
  • Mesh export time is improved.
  • Fix refraction + volume on CPU.
  • Fix CPU crash for using "Opacity" AOV with volume objects.


  • These Blender Nodes are not yet supported:
    • UV Map (selecting which map)
    • Attribute Node
    • Node Groups
    • Hue Saturation Node
    • Various Noise nodes
  • AI-Accelerated Denoiser is Windows only.
  • Files made in the Blender 2.79 version of the plug-in are not yet automatically converted.
  • Windows installers prompts for Blender location twice.  This is due to Blender 2.80 being in Beta.
  • GLTF and RPR export are not yet supported (Blender 2.80 has its own GLTF exporter)
  • LWR denoise filter does not work on macOS.
  • A nightly beta build of Blender after 3/27/2019 is required


  • Object space lookup enabled in shader
  • Fixed a crash when removing emissive shader while interactive rendering
  • Fixed a crash with adaptive subdivision
  • Fixed artifacts on NVidia cards with curve objects
  • Double sided emission in Uber should work
  • "Hide Emitter" on particle or hair system is respected
  • Fix geometry corruption in isometric view
  • Normal map strength more closely matches Cycles now
  • Mesh export time is faster in many cases
  • Fix corruption in interactive view with adaptive sampling enabled
  • Object visibility options are expanded to include reflection/refraction/shadow/ etc visibility.  Furthermore toggling with interactive rendering works
  • Objects can be enabled to act as portal lights
  • Blender Curve/Text/Meta objects are rendered
  • New Nodes supported:
    • Layer Weight
    • Texture Gradient
    • Normal
    • Node Reroute
    • Hue Saturation (only fixed values for now)
    • Combine HSV
    • Separate HSV
  • An "RPR" menu is added to the viewport to enable different render modes like Ambient Occlusion
  • Fixed shadowcatcher
  • Nested node groups in shaders are supported
  • Fix out of place hairs in particle system hair
  • Made material preview swatch renders more iterative
  • Border rendering in viewport works now
  • Volumes are rendered as well as principled volume shader.  Note, volume should be cached.  Volumes might look blocky for now, as a temporary workaround increase volume resolution.
  • Shader menu in "Add Nodes" now has RPR Uber, and Principled, Emission, and a few others.  We want to discourage users from using legacy shaders such as glass and diffuse, etc.
  • RPR render device is saved in preferences, not per scene.
  • Environment light world settings include sun & sky option.  
  • Environment light can be over-ridden for background, reflection, refraction etc.
  • .rpr export format is available
  • RPR AOVs show up in compositor nodes
  • Some denoiser features may be unstable.  Please test ML denoiser and report issues.


  • Render statistics collection.  We are removing the activation key from installers very shortly.  As part of that, instead we are making an optional render statistics collection.  This is easily disabled in the render settings.  However, we encourage users to contribute to the Radeon ProRender ecosystem by leaving this on.  We collect no personal information, simply information about how long a render takes, what hardware was used, how many polygons were in the scene, etc.  With this information we will continue to focus our development of ProRender.  Thank you!
  • Removed Intensity parameter from sun and sky
  • Image textures which are "packed" in .blend file export faster by caching to disk
  • An issue with animated cameras not exporting correctly is fixed.
  • "C" component of RGB Curve nodes is handled correctly now
  • Add RPR Procedural UV Node (CPU only on macOS)
  • Better handling of internal math in complex shader nodes
  • Fix subsurface radius of Principled node
  • Added Conversion of EEVEE specular node
  • Volumes should update in viewport renders
  • IES lights should update in viewport renders

Download from


This is great news!

This is good news.  Is there a Linux version available?

It doesn't seem to be using my CPU on macOS. (Please see attached image)

If I check the top box, Blender crashes. Screen Shot 2019-02-18 at 10.15.33 PM.png

I'm really impressed with the output I've managed to get, and I'm a complete beginner!

Rough edges I've noticed on OS X Mojave:

- installer: first time, asks for permission to control Finder. Nothing else happens, installer says finished. Not installed in Blender. Re-run the installer, permission to access finder already granted, pops up dialog asking for installation location of Blender. Now installed

- CPU rendering: immediate crash, as per roborrender‌'s comment above.

- Animation rendering:

    - preview doesn't seem to always update with rendered frame; output does have updated frames. May have something to do with `samples per view update=1`. When I set it this to e.g. 10, it seems to update the preview more reliably.

    - crashes after rendering 5-10 frames. I suspect it has something to do with other apps using metal. E.g. crashed as soon as a used finder quick-view to preview another render, or immediately after loading a page in safari that had an embedded video.

Looking forward to upcoming updates!

Coming soon for linux!

Sounds like there is a CPU issue.  We'll look into it.

Here are a couple of static renders of a very basic rigid bodies sim (I'm playing around with simulating marble machine/marble run projects for possible use at our makerspace.)

I really appreciate that all the materials are unified; one material setup for Eevee, Cycles, and ProRender. This has greatly reduced my mental overload. This is about the 5th time I've tried to learn blender, and in the past I've been derailed and given up when trying to move from a previz/fast render to a "beauty render", and having the lighting wrong, and none of the materials show up. It's looking like 2019 is the year for people to learn Blender 2.8 (with ProRender!)

Major thing I've noticed is that ProRender seems to handle emissive materials & transparent materials very well with default settings. The yellow ball both has an emissive material and a point light tracking it, offset to the right. Only the ProRender render shows refraction "out of the box."

Again, I'm a complete beginner, this is one of my first scenes. There may be ways of getting this refraction and lighting to work with Cycles and Eevee. But not with pretty much stock settings. And each engine definitely has it's place! I'm loving Eevee for pretty darn accurate renders at incredible speeds!

Eevee Render:


Cycles Render:


ProRender Render:


ProRender does seem to produce more noise than the other engines. I'm hoping that can be fixed, eg with more iterations. Will wait for reliability improvements before trying to bump that though.

If it helps, I have dual Xeon 5680s in a 5,1 2010 Mac Pro, and Mojave.

I greatly prefer ProRender to Cycles, it looks great.

This won't load on windows Blender 2.8. When can we get a correction to solve this?

I was able to do a four-hour Metal 8K image render last night. It *might* be because I set 'samples per view update' to 128. (Or it could have just been luck. My renders crash fairly often too, but this is the first time I increased that value to 128.)

RYZEN 1700x



WIN 10

BLENDER 2.80.44

RPR 2.01

Hey Brian! Thanks to all of you for porting RPR to Blender 2.8 that fast!

Here are some issues i found while playing around a bit:


The viewport render is a lot darker than the final render. The final render (left side) looks right. Both renderd with 50 iterations.

Screenshot (18).png


Particle Systems seem to be calculated as real object in final render. While the viewport render starts very fast, final render syncing every instanced object, which would take several hours.

Wow; will try 128/other powers of 2 for the samples per view update next time I'm in blender.

Really looking forward to seeing the stability improve

Would be great by the way to have the RPR glass shader. I liked the options 'thin glass' and 'caustics'. Very useful features.

We can expose that through Uber


first of all, for me as a Mac user ProRender ist an amazing tool to create fast and realistic Images. Well... or maybe the only tool in terms of GPU computing. I am really hyped about Blender 2.8 and ProRender!

so I want to share my experience with version 2.0.1 and the latest Blender 2.8 Builds.

I Use the Late 2013 Mac Pro with two AMD Fire Pro 700 and MacOS Mojave

Sadly Blender crashes to 90% while rendering an image. Viewport raytracing though works very well.

After making changes to materials, ProRender won't update this in the viewport. The final render in the other hand looks correct (if it doesn't crash)

Rendering with CPU crashes Blender.

Camera view (viewport) does not line up with the render.

Denoising crashes the final render and won't let start the viewport.

I followed roborrender's suggestion and increased iterations from 50 to 128.   Viewport renders works.  Final render worked when both GPU's utilized.  Final render crashes when using only one or the other GPU. 


OS: OSX 10.14.3

Software: Blender 2.80 (blender-2.80.0-git20190225.893fa598319e-x86_64, Blender Foundation)

ProRender version: 2.0.1 

Test Blender File:


GPU Setup: 2 eGPU's

EGPU Chassis: Razer Core X

eGPU #1: AMD Radeon Pro RX 7100 

EGPU Chassis: Sonnet 350

eGPU #2: AMD Radeon Pro RX 480 


Viewport - render worked

Render Image - crashes blender within ~1-2 seconds


Sadly, v2.0.2 seems to crash when CPU rendering is enabled. (It crashes both with CPU Alone and CPU + GPU)

Process:               blender [14449]
Path:                  /private/var/folders/*/
Identifier:            org.blenderfoundation.blender
Version:               2.80 (2.80 2019-02-15, Blender Foundation)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           blender [14449]
User ID:               501

Date/Time:             2019-02-25 18:44:37.042 -0600
OS Version:            Mac OS X 10.14.2 (18C54)
Report Version:        12
Anonymous UUID:        BE9B1EE3-3C57-2A4F-BDB4-9E12F227F2D4

Time Awake Since Boot: 150000 seconds

System Integrity Protection: disabled

Notes:                 Translocated Process

Crashed Thread:        51

Exception Type:        EXC_BAD_INSTRUCTION (SIGILL)
Exception Codes:       0x0000000000000001, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Illegal instruction: 4
Termination Reason:    Namespace SIGNAL, Code 0x4
Terminating Process:   exc handler [14449]

Thread 0:: Dispatch queue:
0   libsystem_kernel.dylib            0x00007fff78951eae __semwait_signal + 10
1   libsystem_c.dylib                 0x00007fff788dc830 nanosleep + 199
2   libsystem_c.dylib                 0x00007fff788dc724 usleep + 53
3   org.blenderfoundation.blender     0x00000001071adb48 WM_main + 24
4   org.blenderfoundation.blender     0x00000001071a998f main + 927
5   libdyld.dylib                     0x00007fff78814ed9 start + 1

Thread 1:
0   libsystem_kernel.dylib            0x00007fff789517de __psynch_cvwait + 10
1   libsystem_pthread.dylib           0x00007fff78a0b593 _pthread_cond_wait + 724
2   libc++.1.dylib                    0x00007fff75ef2bda std::__1::condition_variable::wait(std::__1::unique_lock<std::__1::mutex>&) + 18
3   org.blenderfoundation.blender     0x000000010a1a5553 IlmThread_2_3::Semaphore::wait() + 147
4   org.blenderfoundation.blender     0x000000010a1a2ab2 IlmThread_2_3::(anonymous namespace)::DefaultWorkerThread::run() + 66
5   org.blenderfoundation.blender     0x000000010a1a4fa7 void* std::__1::__thread_proxy<std::__1::tuple<std::__1::unique_ptr<std::__1::__thread_struct, std::__1::default_delete<std::__1::__thread_struct> >, void (IlmThread_2_3::Thread::*)(), IlmThread_2_3::Thread*> >(void*) + 663
6   libsystem_pthread.dylib           0x00007fff78a08305 _pthread_body + 126
7   libsystem_pthread.dylib           0x00007fff78a0b26f _pthread_start + 70
8   libsystem_pthread.dylib           0x00007fff78a07415 thread_start + 13

can't enable today's build, getting this error:

2019-02-26 07:08:18,621 INFO rpr.core [7044]:  RPR Core version 0x10032500
2019-02-26 07:08:18,628 CRITICAL rpr [7044]:  Traceback (most recent call last):
  File "C:\Users\shrisha\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\rprblender\engine\", line 29, in pyrpr_init
    pyrpr.init(log_pyrpr, rprsdk_bin_path=rprsdk_bin_path)
  File "C:\Users\shrisha\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\rprblender\", line 127, in init
    import __rpr
ImportError: DLL load failed: The specified module could not be found.

2019-02-26 07:08:18,628 WARNING rpr.default [7044]:  Failed to load rpr from C:\Users\shrisha\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\rprblender. One more attempt will be provided.
2019-02-26 07:08:18,628 INFO rpr.core [7044]:  RPR Core version 0x10032500
2019-02-26 07:08:18,629 CRITICAL rpr [7044]:  Traceback (most recent call last):
  File "C:\Users\shrisha\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\rprblender\engine\", line 29, in pyrpr_init
    pyrpr.init(log_pyrpr, rprsdk_bin_path=rprsdk_bin_path)
  File "C:\Users\shrisha\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\rprblender\", line 98, in init
    ctypes.CDLL(str(rprsdk_bin_path / 'OpenImageIO_RPR.dll'))
  File "C:\blender\2.80\python\lib\ctypes\", line 356, in __init__
    self._handle = _dlopen(self._name, mode)
OSError: [WinError 126] The specified module could not be found

Traceback (most recent call last):
  File "C:\blender\2.80\scripts\modules\", line 351, in enable
    mod = __import__(module_name)
  File "C:\Users\shrisha\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\rprblender\", line 18, in <module>
    from .engine.engine import Engine
  File "C:\Users\shrisha\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\rprblender\engine\", line 88, in <module>
    assert pyrpr_init(bindings_import_path, rprsdk_bin_path)

hi, there is a option for transparent background in this version? Can't find it anywhere.

Blender 2.8 Error Log (bmw27_gpu.blend)

# Blender 2.80 (sub 45), Commit date: 2019-02-25 20:59, Hash 54ffc4e19dc4
bpy.context.space_data.context = 'MATERIAL' # Property
bpy.context.space_data.context = 'RENDER' # Property
bpy.context.area.ui_type = 'VIEW_3D' # Property

# backtrace
0 blender 0x00000001036247d7 BLI_system_backtrace + 55
1 blender 0x0000000102a99c0a sig_handle_crash + 362
2 libsystem_platform.dylib 0x00007fff7b59bb3d _sigtramp + 29
3 ??? 0x00007000049a8ec8 0x0 + 123145379548872
4 AMDMTLBronzeDriver 0x00007fff4433ef7d -[BronzeMtlComputeCmdEncoder dispatchThreadgroups:threadsPerThreadgroup:] + 190
5 libTahoe64.dylib 0x000000011864d8ea _ZN3adl15DeviceMetalImpl8dispatchEPKNS_8LauncherE7MTLSizeS4_ + 346
6 libTahoe64.dylib 0x000000011864c9ba _ZN3adl13LauncherMetal8launch2DEPNS_8LauncherEiiiiPNS_10SyncObjectERf + 186
7 libTahoe64.dylib 0x000000011864b45f _ZNK3adl11DeviceMetal10fillBufferENS_10BufferInfoEPvi + 959
8 libTahoe64.dylib 0x000000011864b08b _ZNK3adl11DeviceMetal11clearBufferENS_10BufferInfoE + 27
9 libTahoe64.dylib 0x000000011855282a _ZN5Tahoe18RtGpuPathTraceImpl18directIlluminationEPKNS_18MaterialSystemBaseEPKNS_10WorldRTGpuENS_4int2ES7_RKS7_PKNS_15RayCastFuncBaseERN3adl13ThreadsToExecEPNSD_6BufferINS_3RayEEEPNSG_INS_3HitEEEPNSG_IiEEPNSG_INS_11ShadingDataEEESJ_SM_SO_SR_RKNS_18RtGpuAlgorithmBase12RenderTargetERKNS_6OptionEPNSG_INS_6float4EEE + 730
10 libTahoe64.dylib 0x0000000118558680 _ZN5Tahoe14RtGpuPathTrace18directIlluminationEPKNS_10WorldRTGpuERKNS_4int2ES6_S6_PKNS_15RayCastFuncBaseERN3adl13ThreadsToExecERKNS0_9IsectDataESF_RKNS_18RtGpuAlgorithmBase12RenderTargetERKNS0_7OptionsEPNSA_6BufferINS_6float4EEE + 96
11 libTahoe64.dylib 0x000000011855663f _ZN5Tahoe14RtGpuPathTrace10renderImplEPKNS_10WorldRTGpuENS_4int2ES4_S4_NS_18RtGpuAlgorithmBase12RenderTargetENS_6OptionEib + 2735
12 libTahoe64.dylib 0x00000001185554f4 _ZN5Tahoe14RtGpuPathTrace6renderEPKNS_10WorldRTGpuENS_4int2ES4_S4_NS_18RtGpuAlgorithmBase12RenderTargetENS_6OptionE + 1380
13 libTahoe64.dylib 0x0000000118531dcd _ZN5Tahoe10WorldRTGpu6renderENS_4int2ES1_S1_NS_6OptionEb + 1325
14 libTahoe64.dylib 0x000000011853294d _ZN5Tahoe10WorldRTGpu6renderENS_4int2ES1_PNS_15FrameBufferBaseENS_6OptionE + 461
15 libTahoe64.dylib 0x00000001185b7f8a _ZN5Tahoe17RenderContextNode6renderENS_4int2ES1_PNS_15FrameBufferBaseERj + 1050
16 libTahoe64.dylib 0x000000011843bfab _ZN5Tahoe3Api6renderEiiiiPNS_4NodeE + 171
17 libTahoe64.dylib 0x0000000118463e93 _ZN5Tahoe8Renderer10RenderTileEjjjj + 1091
18 libTahoe64.dylib 0x0000000118463038 _ZN5Tahoe8Renderer6RenderEv + 88
19 libRadeonProRender64.dylib 0x00000001175fd0e0 rprContextRender + 176
20 libffi.dylib 0x00007fff79607f6c ffi_call_unix64 + 76
21 ??? 0x0000000117de9e30 0x0 + 4695432752

RYZEN 1700x




BLENDER 2.80 (26.02.2019)

RPR 2.02 does not work on my Computer.

The fixed Version of 2.01 did.

2019-02-26 23:19:38,832 rpr.core [4284]: INFO RPR Core version 0x10032500
2019-02-26 23:19:38,838 rpr [4284]: CRITICAL Traceback (most recent call last):
File "C:\Users\Johannes\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\rprblender\engine\", line 29, in pyrpr_init
pyrpr.init(log_pyrpr, rprsdk_bin_path=rprsdk_bin_path)
File "C:\Users\Johannes\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\rprblender\", line 127, in init
import __rpr
ImportError: DLL load failed: The specified module could not be found.

2019-02-26 23:19:38,839 rpr.default [4284]: WARNING Failed to load rpr from C:\Users\Johannes\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\rprblender. One more attempt will be provided.
2019-02-26 23:19:38,839 rpr.core [4284]: INFO RPR Core version 0x10032500
2019-02-26 23:19:38,840 rpr [4284]: CRITICAL Traceback (most recent call last):
File "C:\Users\Johannes\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\rprblender\engine\", line 29, in pyrpr_init
pyrpr.init(log_pyrpr, rprsdk_bin_path=rprsdk_bin_path)
File "C:\Users\Johannes\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\rprblender\", line 98, in init
ctypes.CDLL(str(rprsdk_bin_path / 'OpenImageIO_RPR.dll'))
File "C:\Users\Johannes\Downloads\blender-2.80.0-26.02\2.80\python\lib\ctypes\", line 356, in __init__
self._handle = _dlopen(self._name, mode)
OSError: [WinError 126] The specified module could not be found

Same problem here.

Not yet.

Sorry about that.  Uploaded a new windows build that I tested to work here.  Please give it a try.

This missing file is causing crash on MacOs (Mojave) on MacBook Pro.....PR 2.0.2?



Realized how cryptic this was:

1) Debugger => Visual Studio Code with Blender Development Extension

2) Addon      => Blender ProRender 2.0.2

3) Blend File => bmw27_gpu.blend

Didn't comprehend the specificity of "bmw27_gpu.blend" content in tracking absolute file path!

"build_darwin" is from SVN repository where dependencies are added when Blender source is downloaded from Github....

However, there is no "/deps" subdirectory in build_darwin...So, missing file....I'm so confused. 

Hey, thanks for the update.

Just for feedback:

I think Uber shader is missing by accident at least in windows version of RPR 2.0.10

Hi, in MacOS Mojave, can't activate ProRender plugin. Tried 2.0.2 and 2.0.10 ( I think that 2.0.1 worked). Blender official beta and newest build from today. Nothing helped.

When You will provide transparent background?

Keep good work  

Zrzut ekranu 2019-03-2 o 12.23.13.png

I think you have two versions of the plugin installed?

Yes it's true, second is for Blender 2.79. I understand that I have to delete the old version for testing new?

I deinstalled all plugins, nothing helped with Blender 2.8. In 2.79b work ok, but in newest build of 2.79 there is problem too.

hi, i had to maually install this version from addon with macos, as even if it said installed after pointing to application folder it was not in the addons list...

anyway, i have even tried to install the material library but unfortunately rhere is nowhere to be found on 2.8... is it compatible at all?

Material Library now support only Blender 2.79. Thank You

I installed ProRender beta 2.0.10 in the directory of Blender 2.8 daily beta (march 5).

I see the add-on, but activation crashes Blender.

Console crash log: "TahoeContext: can't create Tahoe object"

Mac OS X 10.13.6, iMac Pro w Radeon Pro Vega 56

Any ideas? Thanks!

At this point i just want to thank you for writing a rock stable renderer, even at this very early stage. I played around with the addon The Grove 3d and i did not experience a single crash since i use ProRender for Blender 2.8. RPR just gave me the error output in console window and i changed the issues. Alphamapping works, particle systems as well.


2.0.15 did not install for me: rpr files stayed in /Users/Shared/.

I manually copied them to ~/Library/Application Support/Blender/2.8/scripts/addons

--> Add-on appeared in Blender 2.8 daily build prefs, but activating still crashes Blender.

(iMac Pro, Mac OS X 10.13.6, Vega 56)

I had exactly same issue on my iMac Pro.
To finish installation manually:
1. After installing the plugin from RadeonProRenderBlender_2.0.15.dmg
2. Go to users/shared/radeonprorender/blender/addon
3. Copy
4. Go to users/"username"/library/applicationsupport/blender/2.80/scripts/addons/ and paste the (cmd+shift+. to see hidden "library" folder) 
5. Unzip the, you should have rprblender folder in addons folder

Now go and activate addon in blender preferences. 

The problem I couldn't solve so far - installation of materials library. 

I should have known better....but assumed overwrite of Addon folder when unzipped.

Suggest adding delete folder contents before unzipping Addon....To avoid "file not found" error.

RYZEN 1700x



WIN 10


RPR 2.015

Sadly i again can't install the addon.

I tried uninstalling and reinstalling Blender and RPR.

in the directory C:\Users\Johannes\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons the RPR folder isn't there after installation.

So RPR isn't listed in Blender Addons at all.

little report

2.0.15 with denoise and CPU still rendering blank image on macbook pro os Mojave.

Instalation still has to be done manually from the shared folder where the installer is put as installer do not install the add-on automatically into blender

I just today found this. Just got my Radeon RX580 on Friday. I'm using the most recent build of 2.8 (downloaded today, March 10) under Win 7 Pro 64-bit.

When I install it, nothing shows up anywhere for 2.8. No addon is installed. Anywhere. Not in the Program Files location, not in my User/Roaming location.

I'm LOVING the addition of mapping support!

But sadly 2.0.15 crashes on MacOS when CPU rendering is enabled. (Just like all previous versions)

Blender crashes instantly for me when i try to enable the add-on.

Are you trying to "enable Addon" in User Preferences or "install Addon" from download?

I use the downloaded .msi installer to install ProRender. When I go into Blender to enable it, it is nowhere to be found. It's simply not there. Then when I look in the directories where it is supposed to be installed, it is simply not there. I have no idea where the installer is trying to put it, but it SHOULD be in \%username%\appdata\roaming\blender foundation\2.8\scripts\ right? Either that or directly in the 2.8 directory structure. Possibly in the general user directory structure.
However, it is simply nowhere.

same here

Same issue with MacOS installer...which I'm more familiar with.  The MacOs installer unzips an to a local directory...and installs to ~/Library/Application Support/Blender.....This was broken in 2.0.15 (Apparently) for both installers. There was a workaround for MacOS but I haven't seen a similar workaround for Windows? Assume it will be fixed in next release.

AHA! Someone in another thread (  ) solved it for me.
For some insane reason, it "installs" the plugin to C:\Program Files\AMD ....
Going into there and digging down, there's an file. Going into Blender and manually installing THAT zip file does indeed install ProRender.
Hope that helps. What a pain.

This works for me!

I asked myself, where it was installed, but did not finde the directory. Thank You so much!

Version history
Revision #:
1 of 1
Last update:
‎02-15-2019 03:48 PM
Updated by: