Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

Adept II

Catalyst 12.8 recognizes only 4 of 5 GPU and clGetPlatformIDs() crashes

It´s seems there are BUGs for multi GPU in the latest whgl driver of AMD. Only 4 GPU of 5 are correct recognized. The Catalyst 12.6 has done that correct.


The first call to clGetPlatformIDs(0, NULL, &numPlatforms); crashes like described before in the discussion:

clGetPlatformIDs() crashes with 5 GPUs Catalyst 12.6 whql

but it happens more often now. It crashes again in the aticaldd64.dll.



Is their an explicit testing for OpenCL applications with multi GPU configs (more than 4 GPU) at AMD side, because that errors happens since the new CGN architecture is released. That is my fourth post to that theme and I not the alone with that problems.

My Machine config is:

HP Z820

5x HD 7950 - four in a Cubix GPUXpander.


Windows 7 Ult x64

Best regards Nils.

6 Replies

I've forwared your post to the right person. 

Adept II

The unofficial Catalyst Beta 9.00-120809-145094 has the same Problem with recognizing all GPU only 4 of 5 are usable. Also the crash sometimes during the first call to clGetPlatformIDs(0, NULL, &numPlatforms); but now not in the aticaldd64.dll anymore.  Now the file is called amdocl64.dll, new name old BUG.   eventlog2.png

That only for info. I will report to AMD issue.... May be sometimes in far future the multi GPU support for AMD cards exists.

Journeyman III

Was this issue ever fixed in any version?  I seem to be seeing the same issue with 13.3 beta???

Journeyman III

My configuration with this problem as follows...

I have a new MSI Z77A-G45 motherboard and 7 new HIS 7950 gpus. Brand new windows 7 x64 ultimate installation. Running AMD 13.3 beta drivers and AMD APP SDK 2.8 but tried 13.1 and 12.8 as well. Attaching cards with x16 to x1 adapters. On more than 4 cards I splice the adapters to molex for power. Using dual XFX 850 psu. This setup is for litecoin mining.

My issue is I never get more than 4 cards to be recognized. Has nothing to do with what adapters I use for power. I have tried the vga to dvi dummy plug and it makes no difference. I have tried the crossfire adapters and that makes no difference. When trying different catalyst version I tried both the AMD Catalyst Un-install Utility and atiman uninstaller 6.3.1.


Hi dirtrider,

It seems you have done a lot of OpenCL work recently. Thanks for reporting the issues faced.

More than 4 AMD GPUs certainly seem to work. Check

These russian scientists have been working with different generation of AMD cards in multi-gpu configuration. So it is certainly possible. You can try contacting them probably.


Hi dirtrider. Only 12.6 and 13.1 can recognize more than 4 GPU under Win 7 12.6 found 5 and 13.1 up to 7 GPU. But 13.1 has an Handle leak. 13.2 and 13.3 beta recognize also only 4 GPU again but their is dead lock issue with multiple context multiple gpu tasks. We buyed now profi GPU W8000 (AMD advertize with HPC possibilies) but the driver has the same problem, it recognize only 4 GPU with 9.003.3 driver. I opened a case on AMD support, but no anwser until now. It seem only under linux GPGPU with many GPU is possible but that is also no option for me.