4 Replies Latest reply on Sep 3, 2008 2:27 PM by Methylene

    Problems setting up in Ubuntu 8.04

    Methylene

      I know that ubuntu is not currently supported, however through alien I have gotten brook+ and CAL to install.  I haven't bothered even testing trying to code something myself as the demos are erroring, and after trying to install the 8.8 drivers again things went haywire and I had to do a reinstall.

      What's interesting is that now I am just using the ubuntu xorg-driver-fglrx-envy package for my driver and this is what I get for the basic demo...

      Locking assertion failure.  Backtrace:
      #0 /usr/lib/libxcb-xlib.so.0 [0x7f18aace297c]
      #1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_unlock+0x24) [0x7f18aace2a84]
      #2 /usr/lib/libX11.so.6(_XReply+0x10f) [0x7f18ac222f4f]
      #3 /lib/libamdcalrt.so [0x7f18acb8f197]
      #4 /lib/libamdcalrt.so [0x7f18acb8ed53]
      #5 /lib/libamdcalrt.so [0x7f18acb8e429]
      #6 /lib/libamdcalrt.so(calInit+0x35) [0x7f18acb95a45]
      #7 ./basic(__gxx_personality_v0+0x447) [0x40235f]
      #8 ./basic [0x403c48]
      #9 /lib/libc.so.6(__libc_start_main+0xf4) [0x7f18ab79b1c4]
      #10 ./basic(calclImageGetSize+0x52) [0x4020ea]
      Locking assertion failure.  Backtrace:
      #0 /usr/lib/libxcb-xlib.so.0 [0x7f18aace297c]
      #1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x15) [0x7f18aace2a15]
      #2 /usr/lib/libX11.so.6 [0x7f18ac222323]
      #3 /usr/lib/libX11.so.6(XFreeGC+0x18) [0x7f18ac1fe9a8]
      #4 /usr/lib/libX11.so.6(XCloseDisplay+0x4c) [0x7f18ac1f788c]
      #5 /lib/libamdcalrt.so [0x7f18acb8ed62]
      #6 /lib/libamdcalrt.so [0x7f18acb8e429]
      #7 /lib/libamdcalrt.so(calInit+0x35) [0x7f18acb95a45]
      #8 ./basic(__gxx_personality_v0+0x447) [0x40235f]
      #9 ./basic [0x403c48]
      #10 /lib/libc.so.6(__libc_start_main+0xf4) [0x7f18ab79b1c4]
      #11 ./basic(calclImageGetSize+0x52) [0x4020ea]
      INPUT      : Matrix I where I(x,y) = (y * WIDTH + x)                      
      OPERATION  : Multiplying input matrix by 0.5                              
      OUTPUT     : Printing 8x8 submatrix of output                             
      KERNEL     : IL                                                           
                                                                                
      (0.0,0.5) (0.5,1.0) (1.0,1.5) (1.5,2.0) (2.0,2.5) (2.5,3.0) (3.0,3.5) (3.5,4.0)
      (128.0,128.5) (128.5,129.0) (129.0,129.5) (129.5,130.0) (130.0,130.5) (130.5,131.0) (131.0,131.5) (131.5,132.0)
      (256.0,256.5) (256.5,257.0) (257.0,257.5) (257.5,258.0) (258.0,258.5) (258.5,259.0) (259.0,259.5) (259.5,260.0)
      (384.0,384.5) (384.5,385.0) (385.0,385.5) (385.5,386.0) (386.0,386.5) (386.5,387.0) (387.0,387.5) (387.5,388.0)
      (512.0,512.5) (512.5,513.0) (513.0,513.5) (513.5,514.0) (514.0,514.5) (514.5,515.0) (515.0,515.5) (515.5,516.0)
      (640.0,640.5) (640.5,641.0) (641.0,641.5) (641.5,642.0) (642.0,642.5) (642.5,643.0) (643.0,643.5) (643.5,644.0)
      (768.0,768.5) (768.5,769.0) (769.0,769.5) (769.5,770.0) (770.0,770.5) (770.5,771.0) (771.0,771.5) (771.5,772.0)
      (896.0,896.5) (896.5,897.0) (897.0,897.5) (897.5,898.0) (898.0,898.5) (898.5,899.0) (899.0,899.5) (899.5,900.0)

       

      How can I see output if it's not working properly?!

        • Problems setting up in Ubuntu 8.04
          Methylene

          I guess it is doing these operations on my CPU because currently my 3870 isn't even configured or setup.  Also it said on another demo "hardware does not support this shader".

          I'm going to see if I can find anything on setting up two x servers or at least have two different devices and 2 different drivers... I was previously getting an error about XFree86 when I had the firestream driver installed on the 3870.  Still saying locking assertion failure then too I think.

          So if anyone could help me set up my HD3200 with a full 3D driver and the 3870 with the firestream driver, that would be much appreciated.

            • Problems setting up in Ubuntu 8.04
              michael.chu
              Hi Methylene,

              Can you try Catalyst 8.6 with your setup and see if that works any better?

              Michael.
                • Problems setting up in Ubuntu 8.04
                  Methylene

                  Hey Mike, thanks for that walkthrough post... I've been trying to extrapolate my own procedure from that post tonight, it's been a little rough.

                  First I installed 8.04.1 LTS off my live CD.  Then I let it do a few updates and messed around with trying to get the radeonhd driver from git to work with the 780G... I dunno I heard a rumor on a forum about some support.  Well the driver never compiled after I wormed through dependency problems I got stuck on something out of drm.h... drm_create_t or I think, as it was a thread parameter .

                  At any rate, I around June when the 8.6 driver was released I started using ubuntu again, and since last may there was still a major bug using the proprietary installer.

                  To reproduce, as I just did a minute ago...

                  With the LiveCD install 8.04.1 LTS (x86_64 of course! its a fairly recent copy too).

                  Install the 8.6 driver, the very one you linked in the walkthrough.

                  Run as root:  aticonfig --initial --resolution=0,1680x1050

                  Restart X

                  You are greeted with a pretty white screen.  I've seen this around on forums all over with no resolutions.  However with the 8.8 drivers there is only one tiny, somewhat comical hitch.

                  When you start x the first few times before the system goes down for a reboot, there is some random data displayed before you get the desktop... It seems to me like a pointer is deferenced before anything was written to that buffer, and it displays garbage... or like the first time it happened... Explicit material sitting somewhere inside your GPU memory unscrubbed!!!   Good thing I don't live with my mother!

                  At any rate, I get better results when I just use the ubuntu repository packages, however, I'm not willing to reinstall a 3rd time tonight, so I'd like to just see how far the 8.8 proprietary driver gets unless maybe I could get some ideas on the white screen o' doom.

                  I don't know if I've given my specs before...

                  • Mobo:  GigaByte GA-MA78GM-S2H (780G)
                  • Memory:  4GB of 1033mhz DDRII Kingston brand memory... Underclocked to 800mhz due to incompatibility problems never resolved :'(.
                  • CPU:  Phenom X3 8650
                  • GFX:  ASUS brand HD3870 with 512mb GDDR4

                  A couple of notes, I am fairly certain of the explanation of the mechanism of this white screen bug.

                  I attempted installation in fedora yesterday and was receiving an error saying no devices were found, and then of course screen0 could not be found.

                  I could never get it to work properly with the 8.6 drivers, so I gave up on fedora because I like Ubuntu much more.

                  I believe the same error is occuring here, and the same xorg.conf file will work on the 8.8 drivers and not on the 8.6.  The aticonfig generated xorg.conf even contains BusIds and it makes no difference specifying them or not as long as I have my onboard gfx disabled.  I noticed something about not being able to find screen0.

                  It's interesting to note that dmesg reports normal initialization of fglrx.  So for whatever reason the only correct way I know how to setup my system doesn't work.  Yet I'm almost positive I fixed this once before back around march... I believe the solution was simply doing aticonfig --initial --resolution=0,1680x1050 .  I think the 8.6 installer was what broke the installation and got me using windows for another 2 months before I started gagging.,,

                  I'm going to get working on installing the CAL/Brook+ packages again and attempt to run the demos again.  I've tried other distros more closely related to the ones recommended and I have just had technical nightmares the whole way.  So I know Ubuntu better and it is certainly an advantage.

                  A little more time and maybe I can inform the community of a sound procedure.  However, I fear the original demo results may mean only partial support.  However, if FindNumDevices only responds if an RV660/RV770 gpu is found then I suppose certain features may have been broken by the 8.8 catalyst package.  Causing that nice shader support error.

                  Are there some features used that aren't supported by the R660?

                  I'll get back with my results from tonight after I peck at it for a few more hours...

                    • Problems setting up in Ubuntu 8.04
                      Methylene

                       

                      I still have no idea how I got the first output there... It was a mix of functionality and the lack thereof, and I honestly couldn't tell you the ingredients to that package cocktail of doom... However I've had some seriously astonishing results tonight

                      Firstly I got the usual assertion errors when running the demos on the 8.8 drivers... It would just abort before getting to any of the juicy stuff.  So after getting tired of things breaking over and over, I decided to test the whole thing inside of the livecd environment.

                      I booted the live cd, installed the 8.6 drivers, installed the alien rigged debian packages for the sdk, and installed libstdc++5... the great part is, I even got a dual display setup working, with and without screens bound to the 3870.  Everything worked great.

                      So I of course decide to install and try the same exact routine!

                      White Screen of Death...

                      Actually with the dual display setup... it's the White Screens of Death...

                      Interesting to note was the cursor going across both screens... The hardy heron background showing up signaling to restart x...   I knew it was all back there.  Further detective work revealed the story in my xorg log...


                      (II) Primary Device is: PCI 01:05:0
                      (II) ATI Proprietary Linux Driver Version Identifier:8.50.3
                      (II) ATI Proprietary Linux Driver Release Identifier: UNSUPPORTED-8.501                    
                      (II) ATI Proprietary Linux Driver Build Date: Jun  2 2008 22:47:36
                      (--) Chipset Supported AMD Graphics Processor (0x9610) found
                      (--) Chipset Supported AMD Graphics Processor (0x9501) found
                      (II) AMD Video driver is running on a device belonging to a group targeted for this release
                      (II) AMD Video driver is signed

                       


                      (II) fglrx(0): VESA BIOS detected
                      (II) fglrx(0): VESA VBE Version 3.0
                      (II) fglrx(0): VESA VBE Total Mem: 16384 kB
                      (II) fglrx(0): VESA VBE OEM: ATI ATOMBIOS
                      (II) fglrx(0): VESA VBE OEM Software Rev: 10.77
                      (II) fglrx(0): VESA VBE OEM Vendor: (C) 1988-2005, ATI Technologies Inc.
                      (II) fglrx(0): VESA VBE OEM Product: RS780
                      (II) fglrx(0): VESA VBE OEM Product Rev: 01.00
                      (II) fglrx(0): ATI Video BIOS revision 9 or later detected
                      drmOpenDevice: node name is /dev/dri/card0
                      drmOpenDevice: open result is 7, (OK)
                      drmOpenByBusid: Searching for BusID PCI:1:5:0
                      drmOpenDevice: node name is /dev/dri/card0
                      drmOpenDevice: open result is 7, (OK)
                      drmOpenByBusid: drmOpenMinor returns 7
                      drmOpenByBusid: drmGetBusid reports
                      drmOpenDevice: node name is /dev/dri/card1
                      drmOpenDevice: open result is -1, (No such device)
                      drmOpenDevice: open result is -1, (No such device)
                      drmOpenDevice: Open failed
                      drmOpenByBusid: drmOpenMinor returns -19
                      drmOpenDevice: node name is /dev/dri/card2
                      drmOpenDevice: open result is -1, (No such device)
                      drmOpenDevice: open result is -1, (No such device)
                      drmOpenDevice: Open failed

                      drmOpenByBusid: drmOpenMinor returns -19

                      (Cut ... Repeats to /dev/dri/card14)


                      (WW) fglrx(0): Failed to open DRM connection
                      (II) fglrx(0): [FB] Find the MC FB aperturs range(MCFBBase = 0xc0000000, MCFBSize = 0x20000000)
                      (--) fglrx(0): VideoRAM: 262144 kByte, Type: DDR2
                      (II) fglrx(0): PCI card detected
                      (WW) fglrx(0): board is an unknown third party board, chipset is supported


                      Also Note the 262144... I have the aperture set to 512mb.  I'm fairly certain this occurs on the 3870 too and I've read vague explanations that there are limitations that have no yet been overcome...


                      (EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
                      (WW) fglrx(0): ***********************************************
                      (WW) fglrx(0): * DRI initialization failed!                  *
                      (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
                      (WW) fglrx(0): * 2D acceleraton available (MMIO)             *
                      (WW) fglrx(0): * no 3D acceleration available                *
                      (WW) fglrx(0): ********************************************* *


                      Anyhow I'm giving this a break for tonight, I may have to wait for the 1.2 release... That's soon right?  I'm downloading the alternate install CD for ubuntu just because I had such different results with the livecd and the actual hard installation.

                      With the new driver coming out I'm not too worried about it, I have faith that it will be resolved so I can play ... Otherwise I'll just have to stay in livecd mode forever and hope not to thread lock by accident!