Nexis

Problem with SDK 1.1 beta on RHEL 5.1

Discussion created by Nexis on Jun 19, 2008
Latest reply on Jun 26, 2008 by Nexis
calinit() crashes

I'm trying to run CAL with a HD3870 under RHEL 5 .1(x86_64) but I'm unable to execute the samples applications. Here is what happens when i launch hellocal:

[root@localhost lnx64]# ./hellocal
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  0 ()
  Serial number of failed request:  8
  Current serial number in output stream: 8

The HD3870 is recognized in the Catalyst Control Center and I've installed the package compat-libstdc++-33-3.2.3-61.x86_64.rpm as it says in the readme_install.txt file.

After reading the topics: 32 bit Fedora 8 + Linux Brook and SDK 1.1 beta on ubuntu Hardy, I've also installed the package libxcb-1.1-4.fc9.x86_64.rpm and tried putting "export LIBXCB_ALLOW_SLOPPY_LOCK=true" before launching hellocal but I still get the same results...

If I take the code of the hellocal project and that I comment everything except the call to calinit(), I still get the same results. If I put a printf() just after calinit(), it isn't even printed so calinit() is just crashing for an unknow reason...

Any Idea?

Thanks for the help

Outcomes