hpcrzrwthaachen

ACML 4.1.0 problems with ifort compiler?

Discussion created by hpcrzrwthaachen on Jun 19, 2008
Latest reply on Jan 20, 2009 by frieds4

So, we are using some versions of Intel compilers (corrently mostly 10.1.015, but we tried the 11 Beta also) and some versions of ACML (3.6.0, 4.0.1).

After download and installation of 4.1.0 version in the very same way the older versions installed, we could not use ANY our Fortran programms with these newest version. The old makefiles worked in pretty way, producing excutables. The ACML was also linked in.

 

BUT: if tries to run these executables, we got repetedly the error message:

forrtl: severe (257): formatted I/O to unit open for unformatted transfers, unit 5, file stdin

Image              PC                Routine            Line        Source            
libacml.so         00002AAAAD74C116  Unknown               Unknown  Unknown
libacml.so         00002AAAAD74B316  Unknown               Unknown  Unknown
libacml.so         00002AAAAD72793A  Unknown               Unknown  Unknown
libacml.so         00002AAAAD70E85C  Unknown               Unknown  Unknown
libacml.so         00002AAAAD70DDC4  Unknown               Unknown  Unknown
xlintsts           0000000000497A5A  Unknown               Unknown  Unknown
xlintsts           0000000000413CA7  Unknown               Unknown  Unknown
xlintsts           00000000004053C2  Unknown               Unknown  Unknown
libc.so.6          00000030A6A1D8A4  Unknown               Unknown  Unknown
xlintsts           00000000004052E9  Unknown               Unknown  Unknown

 

 

The older versions of ACML works well. Surprisingly, come C programms we tried ot, produsec no problems.

 

Any idea?

 

Best regards,

P

Outcomes