AnsweredAssumed Answered

PowerColor 5700XT Red Devil - amdkmdag.sys Video Engine Timeout in Oculus Home.

Question asked by steelr4t on Oct 14, 2020
Latest reply on Oct 17, 2020 by steelr4t

CPU: Ryzen 5 3600XT

M/B: Asus ROG STRIX Gaming 450-F

RAM: 2x16GB Corsair DDR4

GPU: PowerColor 5700XT Red Devil

PSU: Corsair RM750

O/S drive: 240GB Kingston SSD

Data Drive: Seagate 2TB SSHD
3x BenQ 24" 1080p monitors
Oculus Rift S.

 

Obviously this error is no stranger to 5700XT owners and reading around it seems particularly prevalent with the PowerColor cards.  What's particularly odd about my situation is that the card is about 6 months old and only started exhibiting these problems to the level I've got to now since upgrading to the above system.  The only new components of the new system are M/b, CPU, RAM, SSD drive and PSU.  This obviously suggests that there's something wrong with one of the new components (RAM, CPU or M/b - I've even tried it with the original PSU and get the same problems), but I'm floundering a little on how to see what is the likely culprit.  All the symptios seem to point to drivers, but I'm pretty sure I've exhausted all of those possibilities.

 

Bear in mind this is a clean Windows 10 install from scratch on the SSD drive.

 

After tearing my hair out for a couple of weeks, these are the things I've tried:

 

* DDU uninstall in Safe Mode and reinstall of the drivers, both with and without the Adrenaline Software.

* Roll back of drivers to 20.7.1 and PowerColors website one which is 20.4.2
* Currently running 20.9.2, and I've tried 20.9.1 as well
* TdrDelay key in the registry set to 8

* sfc /scannow now on the OS and full chkdsks of both diskdrives

* ensure Windows update is as up to date as I can get it

* scoured AMDs website for all the latest chipset drivers

* ensured the M/B is running the lastest BIOS
* various undervolt settings (though I'll admit, I'm very much a noob when it comes to tweaking those kinds of things, so tend to leave well alone!)

* I've removed all the O/C settings on the motherboard and turned off the hyper threading (doing this has gotten me to a relatively stable position with the exception of the symptoms below)

* Processor temps run between 40 and 50; GPU temps never get much more than 80.

* There are minimal tray applications running.

 

The symptoms tend to be game or Oculus related and will either be totally fine or specific games will crash once you start them from their respective menu screens (presumably when the 3D engine gets going.)

 

In the Oculus, Home will start OK and will often get stuck in a black screen and restart loop when I put the headset on.  A combination of PC restarts and / or sometimes just restarting the Oculus service will get it in a position where I can launch a game without it crashing.  Once that happens it'll be fine.  We're talking Assetto Corsa, Project Cars 2, DIRT Rally 2, Elite Dangerous.  All those are fine. These games I tend to launch directly from Steam anyway, or an ACs case from the Content Manager.  So this tends to suggest a problem with the Oculus software or incompatibility therein.

 

In RaceRoom I can select the cars and track, and it'll freeze in VR at the "Continue" button before the grid start.

 

Other games I've tried like GTA V, MechWarrior Online and Wreckfest.. again no problems at all.  No Mans Sky is a bit hit and miss, but is in a better place now than it was.  It'll launch and run for an hour or so before it grinds to a halt and crashes; although that's been somewhat of a problem since Origins was released, so I'm not convinced its related.

 

Apologies for the text wall.. if there's anything else I can do to either fix the problem, or isolate which bit of those new components could be faulty so I can send it back, I'm all ears!

Outcomes