AnsweredAssumed Answered

Linux failure to boot on Ryzen 5 3600

Question asked by ckohn on Oct 10, 2020
Latest reply on Oct 16, 2020 by ckohn

I am upgrading a Centos 7.5 system from an AMD Phenom II 1055T processor that has run trouble free for years to one on a MSI B550 Motherboard with a Ryzen 5 3600 processor and I cannot get it to boot.

 

In desperation I have tried live versions of Centos 7.5, Ubuntu 16, 18 and 20.04, Clear, and Debian and I have tried both the 7C91vA0 and 7C91vA43 BIOSes, all with the same or similar result, they get a part screen into the boot and fail. Often the screen indicates "unknown chipset", "ACPI error", or "unknown chip XID 641".

 

I have researched the Net and found that Centos does not support Ryzen and only the vague statement that Ubuntu runs on any amd64, which I understand the Ryzen 5 3600 to be.

 

I am prepared to change MB or CPU or both but not until I have some assurance that it will work.  I think that Centos or RedHat support only a few high end AMD processors and hence am prepared to switch to Ubuntu 20.04, but I don't want to commit until I know that the cpu / MB will work.

 

Any suggestions would be much appreciated and thanks.

 

Carl

Outcomes