AnsweredAssumed Answered

gigabyte x370 K7 update to 3700x - Lost dual channel support.

Question asked by robertoschar on Oct 3, 2020
Latest reply on Oct 7, 2020 by robertoschar

Hi, 

So I updated my Gigabyte x370 k7 mobo from a 1700x to 3700x. After that I noticed an error message when booting up that stated  Memory TPU training error at dimm 0 socket 0.... also noticed that my RAM was half what it was.... from Team Group Dark Pro "8Pack Edition" 32GB (4x8GB) DDR4 PC4-25600C14 3200MHz Dual Channel Kit only 16GB was visible in both BIOS and windows..... 

 

After a lot of experimenting, removing the RAM and trying different combinations.... downgrading BIOS, Updating the BIOS etc. I have come to the conclusion that for some reason my Dual Channel support is no longer active on my motherboard. 

 

Can anyone help me get past this issue or should I go back to my 1700x where everything worked fine?

 

 

Update 1: I put the 1700x just to rule out Motherboard and RAM issues and everything worked as before.... 3.9GHZ overclock stable with the XMP profile on the RAM running smoothly. Makes me wanna find a solution for this even more now.... the 3700x benched ok with CPU-Z... I'm completely at a loss now....

Outcomes