AnsweredAssumed Answered

CPU Dead? Red CPU EZ Debug Light + No Post

Question asked by ereos on Oct 2, 2020

Hi All

 

Red CPU EZ Debug Light and No Post !  Please Help 

 

I have had my desktop for just under 2 years so all parts are compatible however recently I had changed the orientation of my case and components layout (using a ThermalTake v21 mATX case) however i did not move the CPU or Motherboard. The Desktop was working after this and when i switched it off the desktop does the following:

 

Powers to mouse (RGB turns on briefly) for 2 seconds then receives no power

No power to keyboard

No Signal to Monitor

Red EZ Debug Light on my Motherboard (MSI B450M Mortar)

 

I have tried diagnosing the problem and did a thorough research in regards to the potential methods of fixing this however I have not succeeded:

 

I have tried the following below:

 

  • Reseated Ram into different slots
  • Tried single ram slot
  • Tried a less powerful RAM of 3000mhz DDR borrowed from a friend
  • CMOS Battery Reset
  • CMOS Reset via Jumper Cap
  • Bios Flashback button on motherboard 
  • Attempted Bios Flashback with older Bios and also latest/newer Bios (Tried with 4 different Bios Releases)
  • Had confirmed all cables were connected correctly
  • Diagnosed parts via removing a part per attempt starting from GPU, Wifi Card, Storage Devices SSD and HDD, CPU Fan till it was just the PSU, CPU and RAM Remaining
  • Tried removing from case incase the case was shorting the Motherboard
  • Applied new thermal paste

 

All these failed

 

Can anyone advise?

 

 

My Desktop Specs/Components are:

 

Ryzen 7 2700x

MSI B450M MORTAR

CoolerMaster ML240L AIO COOLER

2x 8GB 3200mhz Cosair Vengeance
Asus ROG Vega 64 8gb OC

240GB Toshiba SSD

2TB HDD Seagate Barracuda
EVGA 650watt PSU

Thermaltake Core V21 mATX Case

Noctua Fan 120mm (for rear fan)
Gigabyte Wifi Card (Forgot name)

 

 

Outcomes