AnsweredAssumed Answered

Ryzen 5 2400g and Sapphire pulse Rx570 mini itx crashing pc

Question asked by nerdbox on Oct 1, 2020
Latest reply on Oct 3, 2020 by nerdbox

Hello I have problem setting up graphics card. So basicly after installing the dGPU and its drivers pc freezes after about 11 minute in Furmar at 1280*980 with 8xMSAA and after oabout 30 minutes in games and after 45 minutes up to hour when pc is idle. This will happen when pc is completly cool and all caps had chance to set to equlibrium. After putting the GPU into another rig it worked fine even at high loads it didnt freez or crash.

Here is my set up:

Proc: Ryzen 5 2400g

MOBO: ASROCK ab350m pro4

RAM: G.skill aegis 2*8 GB 3000MHz c16

SSD: Crucial SSD 500Gb 

PSU: Corsair 450w 80+ bronze 

And GPU (it is used one): Sapphire pulse radeon RX 570 mini tx (it is 4 Gb card)ž

 

So what have I tried. Updating BIOS, updating AMD all in 1 with VGA driver from ASRock, updating chipset from AMD page (only site that provides chipset updates). Installing AMD graphics driver, disabling APUs graphics in BIOS, forcein it to only 64Mb, just enableing it, forceing it without making any buffer chanches, setting it on auto. I have tried chancing PCIe x16 switch to GEN1, GEN2 and auto, chancing PSPP policy and so on. So what is the next step that someone can give me. 

There is possibility that Ryzen 5 2400g with its iGPU isnt compatible with any of the Radeon graphics.

Another problem that I had heard of is the MOBO problem better to say they didnt designed it properly.

 

Sorry for my English

Outcomes