AnsweredAssumed Answered

Can't install Ryzen Master or AMD chipset drivers

Question asked by joshuarogan27 on Sep 30, 2020
Latest reply on Sep 30, 2020 by joshuarogan27
It seems like this issue is present in a pretty wide range of systems. Some other reports of this can be found here and here. The two issues definitely seem to be linked, judging by other user reports.
My System
Hardware:
  • R7 3800X CPU
  • b450 tomahawk max MB
  • 5700XT GPU (Gigabyte Gaming OC)
  • 2x8GB 3200 Crucial Ballistix Sport LT RAM
  • 500GB Kingston A2000 SSD (OS Drive)
  • 750W Gigabyte G750H PSU
Software:
  • Windows 10 Education 10.0.19041 Build 19041
  • Radeon 20.9.1 GPU Drivers
  • 2.01.15.2138 Chipset Drivers
  • Bios version 3.70,
  • No Ryzen Master installed
Ryzen Master
The problem
Installing ryzen master appears to go smoothly. I can click through the installer as normal and I even get a "Successfully Installed" message at the end. However, the installer doesn't actually install anything, not even an installation directory. Here's the log.
Things I've tried
  • Running this tool from microsoft. It doesn't detect Ryzen Master as installed.
  • Installing old versions of Ryzen Master from 3rd Party websites such as guru3d.
  • Deleting pretty much every key that relates to Ryzen Master in my registry
  • Running the various executables created in C:/AMD/RyzenMasterExtract. They either straight up don't work (/AMD Ryzen Master.msi, /MSIFiles/AMD Ryzen Master.msi), have the same issue (/MSIFiles/Qt_Dependencies/Setup.exe), or give the message: "Installation of AMD Ryzen Master from extracted binaries is prohibited." (/MSIFiles/Packages/AMD Ryzen Master UI.exe)
  • Following this post I can create a modified version of the installer that I can acutai, however now I get Error 1720.

 

 

Chipset Drivers
The problem
I cannot install chipset drivers past version 2.01.15.2138. Any later version give this error.
Things I've tried
  • Uninstalling previous versions, with both the AMD cleanup utility and the microsoft tool mentioned above.
  • Running DDU in safe mode, then reinstalling graphics drivers from the AMD website.

 

 

Other things I've tried
  • On top of what I've mentioned above, I've also tried a completely clean installation of Windows 10 Pro on a different SSD with no extra drives attached, ruling out any of my storage devices as the issue. On the clean install, the only programs I attempted to install were Ryzen Master and the Chipset Drivers, but both failed in the same ways mentioned above. To me, this implies either a hardware or firmware issue.
  • I have also cleared CMOS multiple times, changed the BIOS mode to UEFI from BIOS, and flashed the latest bios manually.
  • Disabling windows defender during installation
  • Running a system file checker scan
  • Running the installers as administrator
  • Reinstalling Visual C++ redistributables

Outcomes