AnsweredAssumed Answered

AMD Software not opening, Code 43, eGPU Razer X Core, 5600 XT Troubleshoot

Question asked by tiloki on Sep 25, 2020

Hello,

 

I just got a brand new Sapphire 5600 XT Pulse and a Razer X Core to go with the following laptop: 

  • Dell Inspiron 14 7490, Intel i7-10510U 4 cores
  • Windows 10 1909 64 bit 
  • 8 GB RAM 
  • Thunberbolt 3.1 4 lanes 
  • AMD Card set up in performance mode 

 

I have done the following for installation: 

  • Updated latest system BIOS
  • Updated all drivers 
  • Installed latest TB drivers 
  • Disabled Thunderbolt security in BIOS
  • Connect eGPU and boot 
  • Installed AMD software, tried with both 20.9.1 and 20.4.2; and auto detect

 

So far I haven't been able to get the GPU working as I: 

  • See in ocassions the card recognised under device management Windows saying it's working fine
  • When I try to open AMD Software I always get the "no AMD graphics installed..." 
  • Sometimes I get a Code 43, sometimes it's working fine according to Windows 
  • HDMI from GPU to external display not showing anything 

 

I've tried: 

  • DDU a couple of times from Safe Mode
  • Revert to last Windows version and clean install
  • Install with AMDs detect tool
  • GPU-Z and Intel HD graphics controller show AMD's card 

 

I have seen similar setups working in forums, but so far I haven't been able to get my running. 

 

Attaching images for reference. 

 

Any help, super appreciated as all these are brand new. 

 

Thanks!

Alex

Attachments

Outcomes