AnsweredAssumed Answered

V1000 APU OpenCL

Question asked by tsjorda on Sep 15, 2020
Latest reply on Sep 16, 2020 by tsjorda

I have tried about 10 ways to get OpenCL working on a V1000 APU (V1404i to be exact) and can't get anything working. Worse, the documents that come with the AMD drivers on their website haven't change as the kernel and OS builds have so it's all out of date.


IOMMU is enabled in BIOS


I have tried:

  1. Ubuntu 18.04
    1. pocl-ocl-icd
      1. clinfo only shows processor (expected)
    2. mesa-ocl-icd
      1. clinfo won't show GPU
    3. ROCm DKMS (not officially supported for V1000)
      1. clinfo - seg fault
    4. ROCm OpenCL only
      1. clinfo - seg fault
    5. AMD driver kernel 5.4.2
      1. clinfo - shows GPU through ROCm-OpenCL that was installed through the driver, yay!
      2. execute openCL code -
        1. hangs on kernel execution
        2. concurrent clinfo call un-hangs the code, kills display, hangs. CTRL-C kills it, but clinfo can't be called again until after reboot
  2. Ubuntu 20.04
    1. AMD driver kernel 5.4.2
      1. clinfo - shows nothing because ROCm is no longer installed (despite the included documentation)
      2. Install Latest ROCm-OpenCL (3.7.0) - shows 1 Platform, no devices


All I want to do is get OpenCL working on this device's GPU. Has anyone at AMD tested this?