marcellinux

Install driver amdgpu-pro-20.10-1101037-ubuntu-18.04.tar.xz

Discussion created by marcellinux on Aug 27, 2020
Latest reply on Aug 31, 2020 by marcellinux

System: CPU Intel(R) Core(TM) i5-3470 CPU @ 3.20GHz

hardware: 1:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Baffin [Radeon Pro WX 4100]

OS: Ubuntu VERSION="18.04.5 LTS (Bionic Beaver)"

 

./amdgpu-install:

 

....

Setting up libgl1-amdgpu-pro-ext-hwe:amd64 (20.10-1101037) ...
ln: failed to create symbolic link '/opt/amdgpu-pro/lib/xorg/modules/extensions/libglx.so': File exists
dpkg: error processing package libgl1-amdgpu-pro-ext-hwe:amd64 (--configure):
installed libgl1-amdgpu-pro-ext-hwe:amd64 package post-installation script subprocess returned error exit status 1
Setting up libgl1-amdgpu-mesa-glx:amd64 (1:19.3.4-1101037) ...
Setting up libgl1-amdgpu-mesa-glx:i386 (1:19.3.4-1101037) ...
Setting up libgles2-amdgpu-pro:amd64 (20.10-1101037) ...
Setting up libgles2-amdgpu-pro:i386 (20.10-1101037) ...
dpkg: dependency problems prevent configuration of amdgpu-pro-hwe:
amdgpu-pro-hwe depends on libgl1-amdgpu-pro-ext-hwe (= 20.10-1101037); however:
Package libgl1-amdgpu-pro-ext-hwe:amd64 is not configured yet.

dpkg: error processing package amdgpu-pro-hwe (--configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because the error message indicates its a followup error from a previous failure.
dpkg: dependency problems prevent configuration of amdgpu-pro-lib32:
amdgpu-pro-lib32 depends on amdgpu-pro (= 20.10-1101037) | amdgpu-pro-hwe (= 20.10-1101037); however:
Package amdgpu-pro is not installed.
Package amdgpu-pro-hwe is not configured yet.

dpkg: error processing package amdgpu-pro-lib32 (--configure):
dependency problems - leaving unconfigured
Setting up libegl1-amdgpu-mesa-drivers:amd64 (1:19.3.4-1101037) ...
Setting up libegl1-amdgpu-mesa-drivers:i386 (1:19.3.4-1101037) ...
Setting up amdgpu-lib-hwe (20.10-1101037) ...
Setting up amdgpu-lib32 (20.10-1101037) ...
Setting up amdgpu-hwe (20.10-1101037) ...
Processing triggers for libc-bin (2.27-3ubuntu1.2) ...
Errors were encountered while processing:
libgl1-amdgpu-pro-ext-hwe:amd64
amdgpu-pro-hwe
amdgpu-pro-lib32
E: Sub-process /usr/bin/dpkg returned an error code (1)

 

How can I solve this?

Outcomes