AnsweredAssumed Answered

ubuntu 20.04 driver installation problem Package 'amdgpu-hwe' has no installation candidate E: Package 'amdgpu-pro-hwe' has no installation candidate

Question asked by rm1567 on Jul 30, 2020

I've this errors:

 

Distributor ID: Ubuntu
Description: Ubuntu 20.04.1 LTS
Release: 20.04
Codename: focal

Linux mada-NUC8i7HVK 5.7.1-050701-generic #202006071230 SMP Sun Jun 7 12:32:55 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

 

ada@mada-NUC8i7HVK:~/Downloads/amdgpu-pro-20.20-1098277-ubuntu-20.04$ sudo ./amdgpu-pro-install -y --opencl=pal,legacy
deb [ trusted=yes ] file:/var/opt/amdgpu-pro-local/ ./
Get:1 file:/var/opt/amdgpu-pro-local ./ InRelease
Ign:1 file:/var/opt/amdgpu-pro-local ./ InRelease
Get:2 file:/var/opt/amdgpu-pro-local ./ Release [816 B]
Get:2 file:/var/opt/amdgpu-pro-local ./ Release [816 B]
Get:3 file:/var/opt/amdgpu-pro-local ./ Release.gpg
Ign:3 file:/var/opt/amdgpu-pro-local ./ Release.gpg
Get:4 file:/var/opt/amdgpu-pro-local ./ Packages [106 kB]
Hit:5 http://security.ubuntu.com/ubuntu focal-security InRelease
Hit:6 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:7 http://ro.archive.ubuntu.com/ubuntu focal InRelease
Hit:8 http://ro.archive.ubuntu.com/ubuntu focal-updates InRelease
Hit:9 http://ro.archive.ubuntu.com/ubuntu focal-backports InRelease
Hit:10 https://packagecloud.io/slacktechnologies/slack/debian jessie InRelease
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Selected version '20.20-1098277' (localhost [all]) for 'amdgpu-pro-pin'
The following package was automatically installed and is no longer required:
libllvm9
Use 'sudo apt autoremove' to remove it.
The following NEW packages will be installed:
amdgpu-pro-pin
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/6.004 B of archives.
After this operation, 32,8 kB of additional disk space will be used.
Get:1 file:/var/opt/amdgpu-pro-local ./ amdgpu-pro-pin 20.20-1098277 [6.004 B]
Selecting previously unselected package amdgpu-pro-pin.
(Reading database ... 296988 files and directories currently installed.)
Preparing to unpack .../amdgpu-pro-pin_20.20-1098277_all.deb ...
Unpacking amdgpu-pro-pin (20.20-1098277) ...
Setting up amdgpu-pro-pin (20.20-1098277) ...
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
libllvm9
Use 'sudo apt autoremove' to remove it.
The following NEW packages will be installed:
amdgpu-pin
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/2.684 B of archives.
After this operation, 25,6 kB of additional disk space will be used.
Get:1 file:/var/opt/amdgpu-pro-local ./ amdgpu-pin 20.20-1098277 [2.684 B]
Selecting previously unselected package amdgpu-pin.
(Reading database ... 297001 files and directories currently installed.)
Preparing to unpack .../amdgpu-pin_20.20-1098277_all.deb ...
Unpacking amdgpu-pin (20.20-1098277) ...
Setting up amdgpu-pin (20.20-1098277) ...
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package amdgpu-hwe is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package amdgpu-pro-hwe is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'amdgpu-hwe' has no installation candidate
E: Package 'amdgpu-pro-hwe' has no installation candidate

 

 

:/

Outcomes