AnsweredAssumed Answered

AMDRSSERV.EXE - system error / error 1114

Question asked by mrfun on Jul 30, 2020
Latest reply on Jul 31, 2020 by elstaci

Hi all,

 

I recently bought a new computer unused, its a Ryzen 5 3500x 6core with an RX 570 16GB GPU. The first whole AMD system I have got but also the worst worst worst absolute new computer experience one could have. Especially when shelling out almost $1500 AUD for a ready to go system.

 

I have had it for 4 days, the moment I got past the set up screen I immediately received AMDRSSERV.EXE - system error (screenshot attached) and would see this each time I opened the Radeon software settings but none the less it still opened. I then thought as most would to update the drivers and in the settings this offered to update from 20.4.2 to 20.7.2 and I thought this fix the issue.... BUT instead all this did was bring up a new issue and then was I unable to open the settings at all. I instead received an "load library fail with error 1114" (see 2nd attached)

 

I have since looked at least 15 forums (including this one multiple times) to no luck when any previous questions, everything I have read literally talks about laptops with an internal intel GPU as well as AMD GPU. I have a desktop so this is not for me. Outside of that

 

- I have uninstalled and reinstalled the drivers both as a chipset and individually... no luck, I just get the same error.

- I have changed the registry to 0 for that driver. No luck

- I have installed all windows updates - no luck.

- I have sent an error report and have received no reply. No luck

- I have restored my computer to the day of purchase now twice and am back to the original error. No luck

- I have now missed the deadline of two projects I have had, very bad luck.

- I spent good money on a prebuilt pre installed ready to use system so I could make said deadlines and pay my mortgage as my last prebuilt nvidia based ready to use system... worked as advertised from day 1. Luck Nil, damage catastrophic.

 

This is my last ditch attempt at fixing this before I return the computer for the Nvidia equivalent as I am still within 7 days. Please help, send the police send the ambos or send batman. Whatever fixes this, or allows me to know if I am just beating a dead horse and if I should just return it.

 

Thanks,          

Attachments

Outcomes