itudors

Can't edit my EDC limit on Ryzen 7 2700X, tried everything

Discussion created by itudors on Jul 29, 2020
Latest reply on Jul 30, 2020 by elstaci

Hi Guys

so im running a Gigabyte X470 Aorus Ultra Gaming, on latest F51G bios.


My issue is that I can't get my 2700X to boost properly, while at idle some cores will boost to 4.3ghz all OK, but once its under load, all cores stick to 3.7ghz and won't go more


I figured its because my EDC its set to 120, Ryzen Master in creator mode lets me raise EDC up to 140, but the issue is that when I apply it with 140 EDC, it won't save, I go back to "current" section, it still shows 120 EDC, and can't do anything to raise that limit to 140.


In bios I tried playing with Relaxed EDC throttling option, but nothing changes, my power plan tried Balanced, tried minimum CPU usage in Ryzen Balanced to 20%, nothing wants to work, It just won't boost and won't save EDC 140 at all, always shows like this


Creator Mode TAB:


https://i.imgur.com/FKM6gK8.png


Current TAB after aplying on Creator Mode:


https://i.imgur.com/ple7pJa.png

Any Ideas what can cause this? I don't want to go to a manual overclock, I want to use PBO but it doesnt work...


also my cooler is Noctua NH-D15 Chromax, so cooling isnt a problem, it Idles at 35ºC and max temp is 65ºC, there is plenty of room for OC but It just won't boost...


Please help... Im desperate to get this work

Outcomes