palves

RAID to AHCI

Discussion created by palves on Jul 9, 2020

Hi everyone,

I am really stuck.

My system is a MSI B450 Tomahawk with an AMD 2600. I have 3 HD, 1 NVME (OS drive), 1 SSD and 1 SATA. 

 

I decided to update my bios and after I got the BSOD during booting with the error: "Inaccessible boot device". I revert to the second most recent bios versions and the problem persists. I reinstall windows and nothing changed. So now I have a fresh windows built. 

 

I then went to the BIOS and changed the "Integrated Peripherals" - SATA Mode from AHCI to RAID and the system boots and works. I then went to device manager "Disk drives" and all drives have "AMD-RAID", for instance "AMD-RAID Force MP510 SCSI Disk Device". 

 

I tried to rever to AHCI using this https://support.thinkcritical.com/kb/articles/switch-windows-10-from-raid-ide-to-ahci and no luck. I tried both the normal and the ALT command and same result. I reboot, I go to bios I change to AHCI and then reboots and crashed with the same BSOD. I have to back change it again to RAID and then it boots.

 

So I am going crazy with this and I have run out of solutions. If the solution is to reinstall windows, how can I be sure that it will install with the AHCI drivers? and do I really need to reinstall windows again?

 

Thanks!!

Outcomes