AnsweredAssumed Answered

XFX RX 580 - Monitor instantly losing signal, with sound looping, upon launching any game or benchmark

Question asked by reptilianbrain112 on Jun 19, 2020

Hello,

Just got a custom SH midrange PC three months ago, and it has been going well so far, with the PC able to run basically whatever I have given it. But after today, something must have happened, because as soon as I launch any game (such as Deus Ex: Mankind Divided), and it gets past the splash screen, the GPU fan seems to speed up, then the monitor signal is lost, and the sound loops, which is a textbook GPU crash (I think). The PC eventually restarts on its own. Verified the Events and checked the BugCode and apparently it's got something to do with a TDR crash if the information from Google is correct.

More notable things that did happen are freezes for like 5-10 seconds, and I could predict them by the fact that the game would stop loading scripts or assets (seen in Dishonored 2, the subtitles would be displayed and only after the freeze, the sound would sync up; same issue in Deus Ex: Mankind Divided as well, which are games on two completely different engines) occurring in every game. These did not happen in the first two months of having the PC. Must also mention that the PC starts a bit hard, the keyboard LEDs and the monitor take a while to light up.

My theory is that the PSU must be dying, as it is a very cheap 320 watts one, and using a PSU Calculator, the amount needed would be 480 watts minimum for the system to run at least stable. Should I replace my PSU or is it a different problem entirely?

Thank you in advance!

PC Specs:

XFX RX 580 8GB

8GB RAM DDR3

i5-2400

250GB SSD

500GB HDD

Outcomes