skynight

Disable HDCP with latest Radeon Software driver

Discussion created by skynight on Jun 13, 2020

Hello,

 

I updated today my installation of graphics drivers and radeon software as I couldn't open it anymore after the update of my Windows 10 to the 2004 version.

My problem is the update of Windows 10 has reset my monitor settings, which doesn't like HDCP coming from my RX470.

At 1920x1080@60Hz, if HDCP is enabled my screen flickers, displaying briefly before turning black for several seconds and it loops like this and I need to lower the resolution or switching to interlaced at lower refresh rate to prevent this.

 

With previous Radeon Software, I found that it was HDCP causing this as disabling as turning it off in the override tab (which I found while I was trying to modify every settings I could find) fixed the problem, even when restoring default monitor settings then just turning HDCP off was enough (and was the only setting resolving my problem even after trying some other things, so I'm pretty sure it's the source of my issues) to have my screen displaying correctly.

 

However I can't find this option anymore in latest Radeon Software which is pretty annoying it its not available anymore, as I suppose I'll have to remove HDCP by another way.

 

For information, I found this video which shows the option I'm talking about to disable HDCP at the location it was in the previous version of Radeon Software:

 

How To Disable HDCP In AMD Radeon Display Driver Windows 10 - YouTube 

 

I searched a bit on this forum but the only posts I could find now were only peoples also not able to find this setting anymore.

 

This problem occurs only when Windows has nearly finished booting up, wether drivers or installed or not and using generic ones, but my screen displays perfectly 1080p when connected to my RX470 at boot (from the motherboard UI for example), in grub (which displays the menu in 1080p in my case) and on OpenSUSE (I have no problem to display 1080p wether I'm in an alternative terminal or in KDE/Mate/...etc).

 

My problem concerns only Windows which seems to always enable HDCP by default with generic drivers or Radeon ones, and I need to disable it.

 

Thanks for your help

 

Edit: I reinstalled Adrenalin 19.2.2 and it seems to work on Windows 10v2004, disabling HDCP fixed again my issue (first and only thing I did to be able put back my monitor in 1080p resolution) so I'll stay a bit on this older version though it would be great to have this feature back / find where its hidden now.

Outcomes