AnsweredAssumed Answered

Ryzen 5 2400G can't enter Windows

Question asked by gstvmglhs on Jun 2, 2020

I apologize in advance for any spelling errors!

Hello everyone, I have recently bought a Ryzen 5 2400G as a CPU for my second system (my primary system has a Ryzen 5 1600) and I am unnable to enter windows with it. Already tested in two systems:

System 1:
MSI X370 SLI PLUS

2x 8GB Corsair Vengeance 

WD NVME SSD, Hard Drive from WD too

RX480 8GB Asus Strix

 

System 2:

Asrock A320

1x 8GB Corsair Vengeance

Seagate Hard Drive

GTX1060 3GB from Gigabyte


Here's what happens:
I installed the new Ryzen 5 2400G in my X370 from MSI and I am able to enter the BIOS, I have a display output with my video card and the internal graphics, everything is looking great, but when i try to enter windows I face the loading screen for about 10 seconds until the rotating balls freezes and nothing else happens, when I press the power button it simply turns off, same thing is happening in my Asrock A320. Both boards work fine with my Ryzen 5 1600.

I tried booting from windows from my nvme SSD, my hard drive with SATA interface and even tried to instal a fresh windows from pen drive (latast version) and the same problem happens.

 

Did not try linux nor Older versions of Windows (Windows 7/8)

 

Anyone has a fix for it or some question/suggestion or should I just try to get it RMAed?


Thank you for reading.

Outcomes