AnsweredAssumed Answered

RX 5700 Driver Problems

Question asked by nolotank on May 29, 2020

I bought an XFX Reference RX 5700 from a friend to replace my aging R9 390. He says it worked fine.

 

I've followed the steps to do a clean install (DDU in safe mode, install latest driver from AMD website), but I'm having persistent problems with this card.

 

The problems are as follows:

1. System consistently fails to boot after shutdown. No output to display and "VGA" diagnostic light on motherboard lit up. Usually fixed by flipping PSU power switch, holding power button to drain any stored energy, and then turning PSU back on and starting PC as normal.

2. When PC does boot, the frame rate on desktop and in browsers is very low, mouse movement appears to be about 30fps.

3. Sometimes the PC will boot successfully but Device Manager will read Code 43 on the GPU and the GPU fan runs at high speed constantly. The low desktop FPS issue is not present in this case.

4. Games start and run at full frame rate (GTA V, BeamNG, Aim Lab), but GTA V exhibits frame drops, freezes, and black screens, sometimes even causing an automatic restart and leading to problem #1.

5. Attempting to start Unigine Heaven benchmark results in immediate crash to desktop, regardless of mode selected.

 

I've tried reinstalling drivers, changing the PCI mode in my BIOS from Auto to Gen3, removing the GPU and using Intel graphics to run DDU, flashing to 5700XT BIOS... nothing has made any difference.

 

I am running Windows 10 version 2004 and the latest drivers meant for this Windows version, but I had similar problems

before the Windows update.

 

Am I having driver problems, or do I need to push my friend to help me RMA this card?

 

System Config:

i5-6600k @ 4.4Ghz

16GB Corsair Vengeance LPX @ 3000mhz

512GB SP M.2 NVME Boot Drive

XFX Reference RX 5700

MSI Z170A Krait 3X

EVGA 500BQ

Sceptre E258B 165hz

Outcomes