k0f20k9j0a

Monitors stop working after Control Center is installed

Discussion created by k0f20k9j0a on May 22, 2020

AMD Ryzen7 1800x

ASRock x370 Taichi

2x MSI Radeon R9 380 SLI 

1x ASUS VP28UQGL (DP 4K 60Hz, 1st card)

2x Dell U2312HM (DVI 1080p 60Hz, DP 1080p 60Hz, 2nd card) 

 

Greetings,

 

My monitors work fine when my video cards are installed at the driver level without Radeon software. When I install Radeon 19.12.2 or 20.4.2, my monitors stop working. After installing Radeon, Windows cannot detect multiple monitors using its "Display -> Detect Multiple Displays" function when previously it functioned correctly. 

 

After installing Radeon and the monitors have stopped working, under "Device Manager -> Display Adapters", if I "Uninstall Device" for the 2nd card the monitors start working again, but the cursor is constantly flickering between a normal cursor and a "working" wheel. The flickering stops after the machine is rebooted and the monitors stop working again. 

 

With Radeon installed, if I set the ASUS as the main monitor, it is the only monitor detected. If I unplug everything and set one of the Dells as the main monitor, it will detect a Dell and the ASUS, but not all three. 

 

If I uninstall Radeon, uninstall both display adapters, and then reinstall just the drivers for the R9 380s, everything works again. 

 

Previously I had the same problem with an older AOC 1080p screen that the ASUS replaced. I believe that the problem has something to do with how Radeon manages multiple outputs from the same card, because if I install a separate DP output card (PNY NVS 310), I can get Radeon working with all three monitors detected. 

 

Any ideas what I can do to get all three monitors working with Radeon installed and all monitors connected to the R9 380s? 

Outcomes