axiio

Minecraft not running well after GPU upgrade

Discussion created by axiio on May 13, 2020

Hi,

A few days ago I got rid off my old 10 year old Geforce 9500GT 512mb GPU. I got an Asus Rog-Strix RX570 8G Gaming GPU. For some reason my Minecraft is running very poorly. Before the GPU swap I had around 100FPS-120FPS on very rare occasions FPS dropped to 50FPS at max. What might be the problem? I made sure that I have latest AMD RX570 drivers, latest java and so on. When Minecraft world is loading it seems that whole PC is stuttering. And once again, I never had this problem with my old GPU.

My PC specs:

CPU: Intel Core i3 6100 @ 3.70GHz (ik its a 2 core CPU)

MBO: ASUSTeK COMPUTER INC. H110M-R (LGA1151)

GPU: ROG-STRIX-RX570-8G-GAMING (ASUSTeK Computer INC.)

RAM: 8GB DDR4

Don't tell me that my CPU "Is not good enough to get stable FPS under 20 Render Distance" it clearly is, since I had well over 100FPS with my old GPU at 22 Render distance. Also I have played so CPU intencive games such as GTA V, Far Cry 5 and Cities: Skylines and with those games I got the performance I was expecting (High preset on GTA V: avg:62FPS, High preset on Far Cry 5 avg:58FPS, Medium preset Cities: Skylines avg: 50FPS). And those games have way better graphics. I have dedicated 4GB of ram to Minecraft but that doesn't solve the problem, my CPU and GPU temps are fine (avg~35°C at Idle and avg~51°C after the gameplay for 20 minutes), neither CPU nor GPU is bottle necking. They are at about 45-55% usage also my RAM isn't the problem either, cause as I said I had 100FPS-120FPS with my old GPU. Problems started after the swap.

Outcomes