AnsweredAssumed Answered

Chipset Driver Not Installing

Question asked by pram on May 12, 2020
Latest reply on May 12, 2020 by elstaci

I recently built a new computer and in Device Manager I see that there are some PCI Devices that say their drivers aren't installed. When I try updating them, Windows say it couldn't find any updates. There's also a PCI Encryption/Decryption Controller that says its driver isn't installed too, and it seems like the common solution to fixing that is to install the latest chipset driver. I downloaded the latest chipset from this page, but when I try running the executable, I get this error:

 

 

I tried installing older versions of the chipset from this page, but I get the same error. Does anyone know how to fix this? Here's what my Device Manager looks like for reference:

 

 

My computer specs are:

 

AMD Ryzen 7 3800X

ASRock x570 Taichi Motherboard

Gigabyte 2080 Ti Windforce

G.Skill Trident Z Neo 32GB 3600

SeaSonic 750W 80+ Platinum Certified

 

OS: Windows 10 Pro 64-bit - I upgraded from Windows 7 Pro to get Windows 10 Pro; would that cause any issues?

Outcomes