AnsweredAssumed Answered

RX5700 displayports stop working after restart

Question asked by kirigar on May 6, 2020
Latest reply on May 7, 2020 by pokester

Ok, so this is a really weird issue and I'm kind of at a loss of what to do.

 

I installed this program to stream my switch games to my pc: https://github.com/DevL0rd/SkyNX. It prompted me to install some drivers and I clicked yes and restarted my pc. After having restarted it the monitor in my displayport port didn't receive a signal anymore, my HDMI output works fine however. I have checked with other monitors and have concluded that the GPU is at fault here. I have no reason to believe that this is malware this reddit post: https://www.reddit.com/r/SwitchHaxing/comments/g7mhas/release_skynx_v10_stable_stream_your_pc_games_to/  and the github repository seem legit.

 

I tried booting into my linux installation aswell and that seemed to atleast receive a signal, but the resolution was capped at 640x480. Also the displayport monitors are able to display the bios screen. After this I tried removing the SkyNX drivers but it didn't seem to change anything. How is it even possible that what I install on my windows installation affects my linux installation?

Other things I have tried: Fully removing the drivers with DDU and reinstalling them. Reflashing the firmware of my RX 5700. Fully unplugging the pc and all peripherals for a minute and replugging them. Disabling HDCP Support in the drivers.

 

Does anyone else have any ideas on how to fix this or even what happened? I have contacted the developer about this, but maybe the people here can help me aswell.

Outcomes