AnsweredAssumed Answered

Unable to use display port after installing AMD Drivers 5700XT

Question asked by cybrzr00 on May 3, 2020

Hi,

I have just finished a new build, with a fresh install of windows 10 (build 1909). I currently have 2 monitors with only HDMI inputs, but I have a Powercolor Red Devil 5700XT which has only 1 HDMI, so I am having to use a DP to HDMI Adapter.

 

When starting the system the monitor with the DP to HDMI is the primary, it shows the bios screens and the windows boot screen. As soon as the windows login screen shows, the DP to HDMI monitor switches into stand by, and the HDMI to HDMI becomes primary. When entering Windows and looking for the second display, it is not listed, if I remove the display driver or boot into safe mode the second monitor works, but unfortunately the generic driver doesn't seem to allow multi-monitors.

 

I have updated chipset drivers, tried the latest optional and the recommended drivers from AMD. I have removed the drivers using DDU in safe mode, reinstalled the drivers. It's a clean install of Windows 10. Single monitor over HDMI works fine, but single monitor over DP to HDMI has no signal once Windows has finished booting.

 

This is obviously some sort of driver related issue since the generic driver shows the display just fine. So my question is, how on earth do I get around this? I need a second monitor for working from home at the moment. Is this a known issue? Should I just RMA my card and go with nVidia?

 

My old R9 270X runs both monitors just fine, so I know its related to the 5700XT, and as previously mentioned it is almost certainly related to the drivers. I have been searching all over but just can't find any info.

 

My System is:

MSI MPG X570 Gaming Plus, latest bios installed.

R9 3900X CPU

32 GB 3200Mhz RAM

EVGA 1000W Power Supply

Powercolor Red Devil 5700XT

 

 

 

Thanks in advance.

Outcomes