AnsweredAssumed Answered

Running into issues when manually installing drivers for Radeon RX 5500 XT

Question asked by gijs on May 1, 2020
Computer Type: Desktop computer, custom build
GPU:
Gigabyte Radeon RX 5500 XT GAMING OC 8G
RX 5500 XT - 8GB GDDR6 - PCIe 4.0 x16 - HDMI, 3x DisplayPort
CPU:
AMD Ryzen 5 2600
3.4 GHz - 6 cores - 12 threads - 19 MB cache - AM4 Socket
Motherboard:
Asrock B450 Fatal1ty Gaming K4
ATX - Socket AM4 - B450 - USB 3.1 (Type-C) - Gigabit LAN - HD Audio - HDMI, DisplayPort, VGA
RAM:
Corsair Vengeance LPX
DDR4 - 16 GB: 2 x 8 GB - DIMM - 288-PIN - 3000 MHz - CL15 - 1.35 V
PSU:
Corsair VS Series VS550 (2018)
ATX12V 2.31/ EPS12V 2.92 - 80 PLUS - 100-240 Volt wisselstroom V - 550 Watt - actieve PFC - Europa
Operating System & Version: Windows 10
GPU Drivers: Microsoft Basic Display Adapter
Chipset Drivers: I don't have a clue :(
Background Applications: Steam and discord
Description of Original Problem: I just build this computer and installed windows 10. Updated it as much as I could. The GPU driver is still Microsoft Basic Display Adapter. Everything works fine, except for playing games ofcourse. Updating the GPU driver through windows only updates the Basic Display Adapter, but doesn't install an AMD driver.
Troubleshooting: I tried installing a couple of AMD drivers, both manually and using the auto-detect program from amd.com. As soon as I install an AMD driver, the computer randomly bluescreens sometimes and gives a different error code. I tried googling the stopcodes, but the advise is always to uninstall manually installed drivers and update them through windows, which I can't get to work.
I've uninstalled everything from the computer and re-installed windows 10 to start fresh, but I ran into the same problems.
I've been trying to solve this all day by googling and asking around for help, but I get the same answer everywhere and all the time. It's been a really frustrating day.. The stopcode I've had thus far:
KMODE_EXCEPTION_NOT_HANDLED
PAGE_FAULT_IN_NONPAGED_AREA
IRQL_NOT_LESS_OR_EQUAL
VIDEO_TDR_FAILURE (atikmpag.sys)
KERNEL_SECURITY_CHECK_FAILURE
MEMORY_MANAGEMT
 
If somebody can help me out or point me in the right direction, I'd be so happy. I thought I would be able to play with friends this morning after waiting for this computer for a week and building it all day yesterday. Today has been very frustrating and I am clueless on how to get this computer to run smoothly.
 
Thanks in advance!

Outcomes