monzzy

Unable to install Drivers....... AGAIN! AMD AGAIN!

Discussion created by monzzy on Apr 28, 2020
Latest reply on Apr 28, 2020 by joeperry

So i decided to upgrade my old ASUS Radeon HD 7300 series graphics card which has been used in a work station since 2013. 

I got a Asus Radeon R9 270 which should be an easy upgrade (albeit a replacement power supply was also needed). 

After the physical upgrade of the cards, the system would not install the correct drivers. This failed on so many levels including the following methods

Windows update - failed

AMD Adrenalin 2020 Edition 20.2.2 and the previous edition - failed

AMD Auto Detect - failed

AMD Crimson 17.1.1 and the previous edition - failed

AMD Catalyst - failed

AMD Drivers only various version - failed

ASUS drivers both version. - failed

 

All of the above leads to the BSOD. The card works under the basic Microsoft driver so why will it not work when using the intended AMD drivers?????

 

After a bit of research it turns out this is a known issues and has been for some time but there doesn't seem to be a work around or a resolution for the issue. 

 

I have read through all of the how to docs which can be found on the AMD website where AMD explain there are many issues which can cause the BSOD including outdated updates, corrupted registry etc etc. So I went through and auctioned all of AMD recommendations yet I am still at the first hurdle. 

 

I have used AMD Cleanuputility on every driver install attempt

I have flashed the latest BIOS on the graphics card which is correctly detected in BIOS and GPUZ. The card works with Microsoft basic drivers. 

Anti-virus and Firewall have been turned off

I have tried install via safe mode

I have tried install without an internet connection

 

 

 

 

The below screen shot shows a driver has been installed after running Crimson 17.1.1 but I can open any of the installed software as it shows the software to be missing. 

 

Ofcourse as soon I try to update the driver using Crimson, it black screens!!! 

 

 

So whats the next stage, what I'm I missing, What else can be done???????

 

BTW the card works. The fans spin, the lights come on every time, it posts with no issues, it shows an image under the basic driver. 

 

Asrock Q77 Vpro

I7 3770

16GB DDR3

650watt PSU

Windows 10 Pro 

Outcomes