AnsweredAssumed Answered

Why does my array break after update 1909?

Question asked by seanvb on Apr 28, 2020
Latest reply on Jun 4, 2020 by pokester

Hey folks,

 

So I have two AMD-RAID Toshiba DT01ACA3 SCSCI Disk devices that are grouped in one array. When I tried to update Windows I got a message saying I needed to update my AMD-RAID drivers because the old drivers did not play nicely with the new update, with this message:
https://support.microsoft.com/en-us/help/4504107/cannot-install-may-2019-update-on-computers-running-certain-amd-raid

After updating it via the AMD-RAID Software provided by AMD the message went away and the update was installed. However, after this update the whole drive is gone from explorer, and programs also cannot access files on it anymore. However, the two disks still show up in device management, and are also recognized by AMD Raid Xpert2. However Windows does not let me make an new array out of them (saying there is no suitable storage found). After restoring to the previous update the drive was found again, and the two disks were also arrayed and everything worked properly. I did not do the original installing of the array (I had the computer built by someone), but I know it was done in Windows itself. Does anyone know why this problem occurs, how to prevent it, and if not: if I can array the two disks again after the update without losing anything that is on there? I've asked EVERYWHERE and keep getting punted around (Windows sends me to their tech forums, who send me here), if anyone has any idea what is going on I would very much appreciate it! Thanks!

Outcomes