sandgoon

R9 390: Black / Blank Screen

Discussion created by sandgoon on Apr 27, 2020
Latest reply on Apr 28, 2020 by hardcoregames™

System Specs:

GPU: Sapphire Nitro R9 390 8GB VRAM

CPU: i5-4690k @ 3.50 GHz, Quad Core

RAM: 8 GB @ 2400MHz (I previously had 8 GB @ 1600 MHz)

Storage: 256 GB SSD + 1 TB HDD (windows on my SSD ofc)

Mobo: ASUS Z97-A-USB31

 

OS: Windows 10.0.18363 Build 18363

 

The Problem:

I am getting reoccurring black screens. I can see that my monitor is obviously on and my PC is still running. It's not a complete black screen-- the display is kind of lit, but that might just be my display in general. However, my keyboard stops responding and that WIN+CTRL+SHIFT+B GPU reboot doesn't do anything. If I'm in a Discord call, I can hear them for a little bit until the audio just straight up goes TRRRRRRRRRRRRRRRRRR.

 

I usually get these black screens after exiting a fullscreen game, while I'm playing a game, shortly after booting up and logging in, and almost always immediately after logging in and starting up a bunch of programs at once. Even just browsing through file explorer will do this. I have tried running OCCT tests-- they always go to a black screen.

 

When it start occurring:

I started getting them just about a few days ago. If my memory serves me right, I was running the latest Adrenalin 20.2.2 since that update came out. I was not experiencing any black screen issues at all. About a week ago (?) I installed the new Windows updates. It was not long after that when I started experiencing this issue.

 

Solutions I have tried:

- A complete fresh install of Windows

- Went into safe mode and DDU'd display drivers. I've DDU'd multiple times to install 20.4.2, 20.2.2, and 19.12.1 independently. Did not work.

- DDU'd drivers and installed 19.12.1. After installing 19.12.1, I went into Device Manager and updated to 20.2.2 from there instead of going through the AMD installer.

- Updated BIOS firmware

- Swapped out my ram, disabled XMP

- Tried to run OCCT tests -- the only test I was able to successfully run for 10 minutes without it going to a black screen was the PSU test. Immediately after the PSU test, I got a black screen.

- Tried turning monitor on/off again during black screen

- Tried unplugging HDMI from monitor and plugging it back in during black screen

- DDU'd with the option to prevent Windows from updating my display drivers to install 20.4.2, 20.2.2, and 19.12.1

 

I am restless. I am losing my sanity. This is driving me nuts. I ran 19.12.1 when it came out completely fine and now I can't even do that. Makes no sense to me. Is it conflicting with the current Windows build I'm running??

Outcomes