AnsweredAssumed Answered

Pro Render for Blender not working in Full quality

Question asked by ssimos76 on Apr 27, 2020

I installed ProRender for Blender 2.8 in a fresh Windows 10 PC with a FirePro W7000 and it works in the viewport in all Render Quality except for the "Full" and when I render the image or crash Blender or returns this error:

 

Read prefs: C:\Users\simow\AppData\Roaming\Blender Foundation\Blender\2.82\config\userpref.blend

found bundled python: C:\Program Files\Blender Foundation\Blender 2.82\2.82\python

2020-04-27 12:05:26,148 INFO rpr.core [16360]: RPR Core version 0x103407

2020-04-27 12:05:26,169 INFO rpr.core [16360]: Image Filters version 0x410000302839b07

2020-04-27 12:05:26,172 INFO rpr.default [16360]: rprsdk_bin_path: C:\Users\simow\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\rprblender

2020-04-27 12:05:26,172 INFO rpr.core [16360]: Registering plugin with: tahoe_path=C:\Users\simow\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\rprblender\Tahoe64.dll, cache_path=C:\Users\simow\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\rprblender\.core_cache\0x103407

2020-04-27 12:05:26,700 INFO rpr.core [16360]: Plugin is registered: plugins=[0], cpu_device={'flag': 16, 'name': 'Intel(R) Core(TM) i7-4930K CPU @ 3.40GHz'}, gpu_devices=[{'flag': 1, 'name': 'AMD FirePro W7000'}]

2020-04-27 12:05:26,701 INFO rpr.core [16360]: Registering plugin with: hybrid_path=C:\Users\simow\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\rprblender\Hybrid.dll, cache_path=C:\Users\simow\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\rprblender\.hybrid_cache\0x103407

2020-04-27 12:05:33,629 INFO rpr.core [16360]: Plugin is registered: plugins=[1], gpu_devices=[{'flag': 1, 'name': 'Unknown AMD GPU'}]

2020-04-27 12:05:34,098 INFO rpr.material_library [16360]: Material library located at C:\ProgramData\RadeonProRender\MaterialLibrary\Xml

Warning: property 'release_confirm' not found in keymap item 'OperatorProperties'

Read blend: C:\Users\simow\OneDrive\Documents\prova.blend

Error: Failed to submit to a queue, VkResult=2

2020-04-27 12:06:20,558 ERROR rpr.init [3076]: RPR call ContextRender(<pyhybrid.Context object at 0x000001F5F9768F48>) returned error code <-18> with error message: '' EXCEPTION: Traceback (most recent call last):

File "C:\Users\simow\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\rprblender\__init__.py", line 96, in render

self.engine.render()

File "C:\Users\simow\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\rprblender\engine\render_engine.py", line 287, in render

self._render()

File "C:\Users\simow\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\rprblender\engine\render_engine.py", line 108, in _render

self.rpr_context.render(restart=(self.current_sample == 0))

File "C:\Users\simow\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\rprblender\engine\context.py", line 108, in render

self.context.render()

File "C:\Users\simow\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\rprblender\pyhybrid.py", line 80, in render

super().render()

File "C:\Users\simow\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\rprblender\pyrpr.py", line 341, in render

ContextRender(self)

File "C:\Users\simow\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\rprblender\pyrpr.py", line 66, in wrapped

raise CoreError(status, f.__name__, argv, module_name)

pyrpr.CoreError: RPR call ContextRender(<pyhybrid.Context object at 0x000001F5F9768F48>) returned error code <-18> with error message: ''

 

I tested Pro Render using CPU instead of GPU and it works fine.

Thanks,

 

Simone

Outcomes