oldar

Sata RAID Drivers 9.0.38 Problems

Discussion created by oldar on Apr 23, 2020

Hello to all!

 

My system has:

 

Mobo: Asus Crosshair VII Hero (WiFi) (Chipset x470)

HDD: 1 x Samsung 850 Pro 256GB (OS)

HDD: 2 x Western Digital Raptor 300BG (RAID)

HDD: 1 x M.2 Adata XPG Gammix S11 Pro 1TB

 

Since last year, when I finished setting up this sytem, everything was running ok. I was checking almost every day for updated drivers and I was always installing them no matter what, keeping the system up to date. Having that in mind, the latest drivers were installed until last week:

Chipset Drivers: 2.04.04.111

RAID Sata NVMe Drivers: 9.3.0.38

With these drivers, I never encountered a problem. I changed nothing from BIOS settings and I was able to see all my devices as it should.

 

The problem started last week, when I had to make a clean install of windows 10. Since then I cannot make the system stable again. After 4 clean window 10 installs, I face these challenges:

 

1. I need to have RAID enable as 2 of my drivers are in RAID. That is why I have Sata Mode > RAID and not AHCI.

2. After I install the latest Sata Drivers 9.3.0.38, I stop seeing M.2 in windows. No device manager, no disk management, nowhere to find it.

3. I set from BIOS NVMe RAID Mode > Enable from Disable, (I never had that setting in my previous software set up) and only then I am able to see M.2 in windows BUT I always have blue screens of Storage Devices all over the place unless I unistall the M.2 when they seem to stop... When I log in, in AHCI mode, I cannot see the RAID but I see all the drivers and it seems like everything is working as intended. If I change back to RAID mode, problems are starting again.

 

I tried to unistall the Sata drivers but when I do that I receive the message "no unistallable drivers found". The funny thing is that I press the unistall button from windows unistallation menu where I can see the AMD Chipset Software (it says Version 2.04.04.111), the GPU drivers as AMD Software (it says Version 20.3.1) and the AMD_Chipset_Drivers (it says 1.11.18.322). I mean there is nowhere the version 9.3.0.38 I installed but I think it's the last one!!!

 

I tried in safe mode, in normal, in RAID and in Sata mode. Nothing worked I cannot change them at all. Only the GPU's drivers I can unistall. The other 2 remaining there...

 

I am too tired to make another clean install after 4 attempts and I was wondering if there is another way to change these drivers with older version while we are waiting to fix them at some point...

 

Thanks in advance!

 

Friendly

Oldar

Outcomes