AnsweredAssumed Answered

OpenCL on E8860 Linux

Question asked by rt0218 on Apr 21, 2020
Latest reply on Apr 27, 2020 by dipak

I am having issues with running an OpenCL program on an E8860 and would like to ask for advice.  

I am trying to get an OpenCL program to run on an E8860 on Linux, preferrably Centos 7  I have tried the dedicated 8860 drivers but these are not available for Centos, so Ubuntu would work.  I have also tried the amd-gpu-pro drivers and the ADM APP SDK 3.0 but neither of these worked.  I could compile but each time the program would run on the CPU and not the GPU.  I know the 8860 only supports OpenCL 1.2 but I could not find out how to use older versions of OpenCL libraries.  

The program runs on an Nvidia GPU, so I know once the drivers and libraries are set up properly, the program should work correctly.  

It should be noted that the GPU is used for computation only and I am not using video from it, and have an embedded graphics chip for video (SM750).

Any advice is greatly appreciated. 

Outcomes