jirkantv

Athlon X4 760k + AMD RX 470

Discussion created by jirkantv on Apr 17, 2020
Latest reply on Apr 19, 2020 by elstaci

Hi,

I have question with my trouble after GPU "upgrade".

 

GigaByte_GA-F2A88X-D3H_(rev._3.0) + X4 760K + GigaBite R9 270X = many year without problems

GigaByte_GA-F2A88X-D3H_(rev._3.0) + X4 760K + Sapphire Nitro RX470+ = black screen at Bios boot

GigaByte_GA-F2A88X-D3H_(rev._3.0) + X4 760K + Sapphire Nitro RX580+ = black screen at Bios boot

 

By below link it should work, by user japweb looks that it works..

https://www.pc-specs.com/mobo/GigaByte/GigaByte_GA-F2A88X-D3H_(rev._3.0)/2452 

 

Is it possible that with newer CPU is support new graphic card or newer Bios will support GPU?

X4 760K (FM2)

https://www.amd.com/en/products/cpu/760k 

 

X4 860K (FM2+)

https://www.amd.com/en/products/cpu/860k 

 

Current board Bios is F5 (last F7 support Godavari and Carrizo), I will update it ASAP (but I´m worry that it will be unnecessary work)

GA-F2A88X-D3H (rev. 3.0) | Motherboard - GIGABYTE Global 

 

Board specification with note..

  • 1 x PCI Express x16 slot, running at x16 (PCIEX16)

* For optimum performance, if only one PCI Express graphics card is to be installed, be sure to install it in the PCIEX16 slot.

(The PCIEX16 slot conforms to PCI Express 3.0 standard.)

* To support PCI Express 3.0, you must install an FM2+ APU.

 

I know that CPU and board are too old, but I´m waiting with upgrade (new CPU+MB+RAM) for some new Ryzen CPU (and situation)

All these card works with R5 1600 (second PC)

 

Thank you for your notes

Jiri

Outcomes