port

Odd Freesync behaviour in DX12 fullscreen mode

Discussion created by port on Apr 17, 2020

So this is going to be an interesting story:

 

Recently I've begun to play WoW again and since I've now own a FreeSync capable display I wanted to enjoy the nice tearing-free fun.

But something certainly odd happens when Freesync (and even without but it's just more noticeable more on that later) is activated on the Fullscreen-Windowed mode in DX12: When you click with your mouse into the 3D-Space of the game (weirdly not including the UI?) the framerate stalls, literally goes to zero or very close to it(I can tell because my Monitor flickers every time it leaves the FreeSync-Range). Normally the Game runs close to 100 FPS but when i furiously click at about 140-180 APM the FPS can go down to the 40's. I've started a Support-Thread in the WoW technical Forum for it but the staff there was supposedly out of his depth. 

(Massive mysterious microstuttering issues at DX12&Fullscreen - Technical Support - World of Warcraft Forums )

Long story short:

- The framerate stalls whenever i click (noticeable microstutter) into the 3D-Space of the game

- The framerate-stalling actually also occurs without FreeSync enabled but less severe (framerate also drops but only to ~70)

- It seems to be related to the monitor/driver interaction (the flickering also, Samsung support blamed AMD driver immediately after my support request with detailed description but it's a long-standing problem with the monitor I knew of)

- how is this happening, it's just occurring in fullscreen-windowed but NOT in windowed mode (which should be equal)

- it just appears on DX12+Fullscreenwindow, DX11 is fine, DX12 windowed is fine (even maximized)

- why is it only when clicking into 3D-space of the game and not the UI?

- is seems to not occur on my very old 1080p monitor (literally ancient tech, one of the first hd-monitors from 2008)

- it is not an issue of WoW-generally on my Laptop (which has no Freesync and a Radeon 550M) there's nothing of this sort

 

 

Setup:
3700X 16GB RAM on a X370 Board 

Gigabyte 5700XT 

Monitor: Samsung 34CF791 (i know this monitor has issues.. :/ but it cannot be only that right?)

rest is supposedly irrelevant

 

Troubleshooting so far:

Updated the Driver+Chipset+BIOS

Reinstalled the Game

Setup a new Win10 partition+Game

Exchanged cables

 

nothing helped

 

 

So um... help pls I'd like to avoid having to exchange the monitor for a loss but I'm honestly out of ideas :/

Outcomes