majarusi

Having problems updating AMD controllers

Discussion created by majarusi on Apr 16, 2020
Latest reply on Apr 17, 2020 by majarusi

Good day/night, so this is my problem:
I have a laptop as this one https://support.hp.com/us-en/drivers/selfservice/hp-pavilion-15-aw000-notebook-pc-series/10862162/model/11715091?sku=V7R92LA
The problem is, when i try to update the driver graphics i get error saying that there is no AMD procesor or that it wasnt correctly installed, i tried the latest adrenalin 20.4.1, got the same error, tried 20.2.0, error, tried catalyst 15.7.1, still error, so i downloaded the default controllers that are given on the link that i put, which are from 2016, tried to update them with windows update, still got error, so im currently using those ones. My laptop has an AMD A10-9600P Radeon R5, and also a R8 (which with the new controllers changed to R5 and R7 M340). This has given me some error with atidxx64.dll in some games and low fps/performance on anothers.
So do i need to install two separate GPU's controllers for it to work? and if so its the case which ones should i download? as there is a lot of R5's and R8's and im not very good at pc stuffs, knowing which ones i should install would really help me. One las thing, i just saw on the support part that there is a "procesors with graphics -> AMD A-Series Processors -> AMD A10-Series APU for Laptops -> 7th Gen A10-9600P APU", if i download this, thats the only one that i need? or also download for the R7 M340? and if so, which first?.
Thx in advice n.n

Outcomes