AnsweredAssumed Answered

RX 5500 XT gets disconnected

Question asked by josete on Apr 12, 2020

Hello!

The video disappears (gets disconnected) almost every day. Then I have to reset the computer and everything goes back to normal ... for a while.

 

System:
Host: htpc
Kernel: 5.4.28-1-MANJARO x86_64
bits: 64
Desktop: KDE Plasma 5.18.3
Distro: Manjaro Linux

Machine: 
Type: Desktop
System: ASUS
Mobo: ASUSTeK
model: Z87-PRO
v: Rev 1.xx
BIOS: American Megatrends
v: 2103
date: 08/18/2014

CPU:
Topology: Quad Core
model: Intel Core i7-4770S
bits: 64
type: MT MCP
L2 cache: 8192 KiB
Speed: 2163 MHz
min/max: 800/3900 MHz
Core speeds (MHz): 1: 2162 2: 2161 3: 2162 4: 2162 5: 2163 6: 2166 7: 2169 8: 2162

Graphics:
Device-1: Advanced Micro Devices [AMD/ATI] Navi 14 [Radeon RX 5500/5500M / Pro 5500M]
driver: amdgpu
v: kernel

Display: x11
server: X.Org 1.20.8
driver: amdgpu
Resolution: 3840x2160~60Hz

OpenGL:
renderer: AMD NAVI14 (DRM 3.35.0 5.4.28-1-MANJARO LLVM 9.0.1)
v: 4.5 Mesa 19.3.5

Audio:
Device-1: Intel 8 Series/C220 Series High Definition Audio driver: snd_hda_intel
Device-2: Advanced Micro Devices [AMD/ATI] Navi 10 HDMI
Audio driver: snd_hda_intel
Sound Server: ALSA
v: k5.4.28-1-MANJARO

 

This is the information I get from the terminal using "journalctl -b -1" after I reboot.

 

kernel: [drm:amdgpu_job_timedout [amdgpu]] *ERROR* ring gfx_0.0.0 timeout, signaled seq=112121, emitted seq=1121>
kernel: [drm:amdgpu_job_timedout [amdgpu]] *ERROR* Process information: process kwin_x11 pid 1477 thread kwin_x1>
kernel: amdgpu 0000:03:00.0: GPU reset begin!
kernel: amdgpu: [powerplay] failed send message: DisallowGfxOff (42) param: 0x00000000 response 0xffffff>
kdeconnectd[1507]: org.kde.pulseaudio: No object for name "alsa_output.pci-0000_00_1b.0.iec958-stereo.monitor"
plasmashell[1479]: qrc:/plasma/plasmoids/org.kde.plasma.volume/contents/ui/DeviceListItem.qml:30:5: Unable to as>
plasmashell[1479]: org.kde.plasma.pulseaudio: No object for name "alsa_output.pci-0000_00_1b.0.iec958-stereo.mon>
kernel: [drm:amdgpu_dm_atomic_commit_tail [amdgpu]] *ERROR* Waiting for fences timed out!
abr 10 14:35:10 htpc kernel: [drm:gfx_v10_0_ring_test_ring [amdgpu]] *ERROR* amdgpu: ring 9 test failed (scratch(0xC040)=0xCAFEDEAD)
kernel: [drm:gfx_v10_0_hw_fini [amdgpu]] *ERROR* KGQ disable failed
kernel: [drm:gfx_v10_0_ring_test_ring [amdgpu]] *ERROR* amdgpu: ring 9 test failed (scratch(0xC040)=0xCAFEDEAD)
kernel: [drm:gfx_v10_0_hw_fini [amdgpu]] *ERROR* KCQ disable failed
kernel: amdgpu: [powerplay] failed send message: DisableAllSmuFeatures (7) param: 0x00000000 response 0x>
kernel: amdgpu: [powerplay] failed send message: DisableAllSmuFeatures (7) param: 0x00000000 response 0x>
kernel: [drm:amdgpu_device_ip_suspend_phase2 [amdgpu]] *ERROR* suspend of IP block <smu> failed -62
kernel: amdgpu: [powerplay] failed send message: ArmD3 (70) param: 0x00000000 response 0xffffffc2
kernel: amdgpu: [powerplay] failed send message: ArmD3 (70) param: 0x00000000 response 0xffffffc2
kernel: [drm:amdgpu_device_gpu_recover [amdgpu]] *ERROR* ASIC reset failed with error, -62 for drm dev, 0000:03:>
kernel: amdgpu 0000:03:00.0: GPU reset(1) failed
kernel: amdgpu 0000:03:00.0: GPU reset end with ret = -62
kernel: [drm:amdgpu_job_timedout [amdgpu]] *ERROR* ring gfx_0.0.0 timeout, signaled seq=112123, emitted seq=1121>
kernel: [drm:amdgpu_job_timedout [amdgpu]] *ERROR* Process information: process kwin_x11 pid 1477 thread kwin_x1>
kernel: amdgpu 0000:03:00.0: GPU reset begin!
kernel: cp queue preemption time out.

I have tried asking for help in the Linux Manjaro forums but nobody knows how to solve this problem.

What can I do?

Greetings!

Outcomes