AnsweredAssumed Answered

New build problems - I think hardware.

Question asked by jenkini87 on Apr 11, 2020

ryzen53600

I've had problems with my PC since I built it. All parts were brand new and should be compatible with each other.

 

Symptoms

 

Bluescreens (BSOD). These occur every now and then, more frequently on newer/more demanding games. Most common errors are IRQL_NOT_LESS_OR_EQUAL and SYSTEM_SERVICE_EXCEPTION but I have seen others.

 

Game crashes (CTD): These never show an error or game has stopped responding etc. These are seemingly random and happen in all games. Event viewer occasionally reports a bad_module_info error, but not always.

 

Random PC reboots: Sometimes the PC will just reboot itself, no errors or warnings here either. The system is back up and running in no time.

 

There are also various errors in event viewer, all the time:

  • application crashes
  • failed modifying runtime statuses
  • unable to start, distributedCOM server
  • windows failed to install a Skype update
  • critical kernal-power
  • session perfDiag logger stopped
  • .NET Runtime error followed by an application error in a game.

 

What Ive tried:

 

Software

 

  • Drivers: Ive made several clean installs of windows, being careful to install the correct drivers from the correct places for specific components. My BSOD errors do not indicate specific third-party drivers, only generic Microsoft drivers.

 

  • BIOS: The latest BIOS for my motherboard causes frequent random reboots without warning. I have reverted to an old BIOS in which the reboots dont occur. I have not tweaked any OC settings manually.

 

Hardware

 

  • CPU: I ran prime95 small FFT torture tests for a few hours - no errors.

 

  • PSU: I swapped my new seasonic 620W for my old Corsair 750W. This made no change. I also ran OCCT power test with no problems.

 

  • RAM: I ran memtest86 and memtest64 for several passes each, no errors.

 

  • Storage: I performed some quick tests with HDDSentinel. My main SSD had 2 bad sectors but otherwise there were no problems with either drive.

 

  • GPU: Ive run OCCTs GPU:3D and GPU:Memtest. Neither gave any errors. I also ran OCCT power test with no problems.

 

  • Motherboard: The fact the latest BIOS causes issues worries me. If all of the other components are ok then this suggests a problem with the motherboard I believe. Im thinking of buying a new one and installing it. Ill be returning the new one if it doesnt fix my problem and Ill RMA/return my current board if it does fix my problem.

 

Specs (speccy):
https://drive.google.com/file/d/1XtncKULz9e2_uAGna2QBauA5-funs0MV/view?usp=drivesdk

Outcomes