cammy

5700XT - Radeon drivers installed cause stuttering audio, especially when mouse moved.

Discussion created by cammy on Apr 2, 2020
Latest reply on Apr 13, 2020 by lossless

Hello guys, so ive had my 5700xt for a good few weeks now, and this issue has been here since i got it.

 

My system specs are;

 

x570-i ROG board

3950x CPU (watercooled)

5700XT (Watercooled)

Corsair Dominator pro 16gb ddr4

samsung 1tb NVME as main storage device.

 

The issue i am having;

 

When i install ANY radeon drivers (Latest or rolledback), i get terrible audio stutter playing youtube or playing some games, sometimes this corrects itself and it works fine, but majority of the time it does not, it seems when it is stuttering - it is made even worse by any moving of the mouse about.

 

I have removed the AMD Drivers with DDU, and the problem goes away and audio is PERFECT, but as soon as i go to install any radeon drivers (i have not tried clean install as it dosent seem to give me any choice to selecting this option) i get my audio stutter issue back.

 

I have tried disabling, then going on to deleting the AMD Audio in hardware manager - and this did not help.

 

DDU - i tried to delete the audio driver ONLY, but it seems to remove the entire driver, thus making games unplayable.

 

Im actually getting quite annoyed with the problem, i have tried the audio onboard the Motherboard, and it does the same, however i use an external DAC (Astro TR - firmware is up to date) and ASTRO TR40 headphones, i have tried another set of headphones into the back of the I/O panel and it does the same, when drivers are removed - the audio works perfectly. 

 

Anyone had this issue before and how do i fix it? Searching didnt really help me find any problems identical to mine.

Outcomes