AnsweredAssumed Answered

Wrong display resolution / generic non pnp-monitor: radeon software at fault?

Question asked by thavis on Apr 1, 2020
Latest reply on Apr 6, 2020 by thavis

Hello everyone,

 

i know it's a lot of text and information... so thank you all very much in advance for your time and effort. 

 

First a little bit of background:

 

I've had this problem for a long time now and had contact with the display manufacturer, MSI support and i also tried numerous forums to get a solution, which obviously did not help since i'm writing this here. It was okay for watching videos so i just gave up in 2017, but the situation has changed and i would like my secondary display to work correctly again, because pdfs and programming scripts are horrible in 640x480. I've been looking around again and tried different approaches and i am at a point where i don't know any further. 

 

The problem

 

There is only the 640x480 (60 Hz) resolution available for my 2nd display. Main display works fine. Setting something else with adrenalin (custom resolution) or tools like CRU does only result in "no signal" error on the display. Windows device manager shows 1st display as PnP monitor and 2nd display as non-Pnp monitor. 

 

The "fun" part:

After fiddling with settings for a few days again, deleting and installing drivers and changing resolutions via CRU, i have now reached a stage in which the display hast the correct solution after startup juuuuust >>until radeon software loads<<. Then both screen flicker once and it shows "no signal" on 2nd display again. Uninstalling radeon software package is not the solution, because then the main monitor doesn't work correctly. 

 

tl:dr:

  • start pc -> device manager shows 1st monitor pnp, but native resolution; 2nd monitor non-pnp with 640x480
  • after changing "non PnP-monitor" resolution with CRU to native 1280x1024
  • start pc -> native resolution on both displays until a few seconds later
  • radeon software loads up -> displays flicker, then 2nd display "no signal"

 

 

See troubleshooting below.

 

System

MSI RX 480 armor 8Gb

Win 10 Pro N 64bit

Ryzen 7 1700X on a MSI X370 gaming pro carbon

32 gb DDR4

drivers and bios are up to date

 

1st / main display: Asus PA238 (connected via DP or HDMI)

native 1920x1080; 19:9

 

2nd / secondary display: fujitsu scaeloview H19-1 (connected via DVI-D)

native 1280x1024; 5:4

monitor input supports analog (vga), analog( DVI-I) or digital (DVI-D, but no dual link bc pins are not connected)

 

Troubleshooting:

  1. display works well on pc with nvidia gtx460. It worked on a system with radeon 5770 and catalyst drivers.
  2. changing to different DVI cables does nothing
  3. connecting only 2nd display does nothing
  4. Installing .inf does nothing or gives "no signal" if it contains information about timing/resolution
  5. clear installing driver package/ radeon software does nothing
  6. clean windows installation does nothing
  7. deinstalling drivers via device manager does nothing 
  8. a few resolutions have worked during different radeon-software-versions since 2017, but never the native resolution (in 2017 1280x720 worked, but was fit to fullscreen, which was horrible as well)
  9. using different custom resolution tools (integrated adrenalin feature or CRU) does result in the display showing "no signal"
  10. GPU scaling on/off does nothing, except if a custom resolustion is set then on keeps 640x480 and off results in "no signal"
  11. deactivating virtual super resolution does nothing
  12. windows device manager event "Not migrated due to partial or ambiguous match"
  13. MonInfo does not show 2nd monitor, but multiple entries of 1st monitor (live, reg-active, reg)
  14. Radeon software correctly identifies the names of both monitors. Device manager does not and shows pnp-monitor (1st display) and non-PnP-monitor (2nd display).

 

I hope this covers everything so far, if anything is missing feel free to ask

Outcomes