AnsweredAssumed Answered

Problem with graphic drivers

Question asked by randommsi on Mar 28, 2020

Hello everyone ,
So here is it ,
Actually i have problems with my graphic card drivers.
so i want to play an emulator for switch called yuzu wich support vulkan.
The problem is that I have 2 Gpu : one is Integrated Gpu (AMD Radeon HD8650G) and other one is dedicated Gpu : R9 M290X . My CPU is a AMD A10-5700M.
I had problems with windows too , so one of the helper in the support (GoldenX86 on their discord server) told me that maybe installing Manjaro will fix the issue .
I downloaded Manjaro and used it normal.
Actually i did all those steps to force Dedicated Gpu to update driver :

sudo mousepad /etc/mkinitcpio.conf look for the MODULES= line and add amdgpu save the file sudo mkinitcpio -p linux54  sudo mousepad /etc/default/grub look for the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"replace it with GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.si_support=0 amdgpu.si_support=1"save the filesudo grub-mkconfig -o /boot/grub/grub.cfg  sudo mousepad /etc/modprobe.d/amdgpu.conf write in the empty file this: options amdgpu si_support=1save it  sudo mousepad /etc/modprobe.d/radeon.conf write in the empty file this: options radeon si_support=0save it  reboot the pc

actually i did them correctly and the system is still normal

after that i installed amdvlk

but when i do the command vulkaninfo or glxinfo | grep OpenGL i get an error :
for OpenGl:

OpenGL vendor string: X.Org OpenGL renderer string: AMD ARUBA (DRM 2.50.0 / 5.4.23-1-MANJARO, LLVM 9.0.1) OpenGL core profile version string: 4.3 (Core Profile) Mesa 19.3.4 OpenGL core profile shading language version string: 4.30 OpenGL core profile context flags: (none) OpenGL core profile profile mask: core profile OpenGL core profile extensions: OpenGL version string: 3.1 Mesa 19.3.4 OpenGL shading language version string: 1.40 OpenGL context flags: (none) OpenGL extensions: OpenGL ES profile version string: OpenGL ES 3.1 Mesa 19.3.4 OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10 OpenGL ES profile extensions:

The guy in the support told me :

your IGPU haunts you even here
DRM 2.50.0
that has to be 3.XX for vulkan to work, and the IGP limits you to the old radeon version 2.5

So i came here to ask for support

i posted a thread here too Problem with graphic drivers - Drivers - Manjaro Linux Forum 

Outcomes