AnsweredAssumed Answered

RX 5700 XT Pulse Not Detected By Device Manager And Radeon Software

Question asked by mickkers on Mar 27, 2020
Latest reply on Mar 27, 2020 by elstaci

I recently upgraded my gpu from a R9 380X to a RX 5700 XT Pulse. The upgrade went fine and everything worked as it should, used my pc for a half hour to an hour. When I turned my pc on again later that night the card didn't give an output, the fans weren't spinning, and only the sapphire logo was on. The system defaulted back to integrated graphics, tried opening radeon software but couldn't since there wasn't a amd gpu detected.

 

Other specs of my pc:

Motherboard: Asrock Z97 Extreme4

CPU: Intel I7 4790K @4.0 GHz

RAM: 2 x 8Gb DDR3

PSU: 850W from Corsair (don't remember which one exactly)

Running 64 bit Win 10

Bios and drivers for other things in the system are updated (mostly), radeon software was on 20.2.2 before the upgrade

Right now I'm running my old 380X

 

Until now I have tried:

-Reseating the card

-Reinstalling Adrenalin with the 5700 installed and got error 173

-Reinstalling after using amd cleaner (didn't expect this to work but was curious)

-Reinstalling after using ddu (was also curious)

-Reinstalling with my old card in the system then putting in the new card

I also tried a few other things I don't really remember that did nothing in the end.

 

I don't know what else to try at the moment, maybe I'm looking at this the wrong way. The help is appreciated, thanks.

Outcomes