AnsweredAssumed Answered

Can't install Radeon ProRender plugin

Question asked by mcseem on Mar 22, 2020

Hi, i can't install Radeon ProRender plugin 2.3.4 for Blender 2.82 in my Kubuntu 18.04. Earlier I used Blender 2.81 by Steam provided and ProRender plugin 2.1 was installed and worked normally. After updating Blender version up to 2.82 the plugin (any version) doesn't installs. I deleted Steam Blender and install separate Blender 2.82 in /home/myuser/bin/blender-2.82a-linux64, but the plugin is still not installed. When I launch the command "./RadeonProRenderForBlender_2.3.4.run /home/myuser/bin/blender-2.82a-linux64" I see the log message "Installing addon to Blender ..." and nothing happens. In this case, the plugin files are installed in "/home/myuser/.config/blender/2.82/scripts/addons/rprblender/" and I can see it in Blender addon list. As I understand it, the problem occurs when enabling the plugin. If I try to enable plugin in Blender addon list, Blender GUI freezes. I can 't figure out what the reason is, help me please.

Install plugin log:

./RadeonProRenderForBlender_2.3.4.run /home/myuser/bin/blender-2.82a-linux64/Verifying archive integrity...  100%   All good.
Uncompressing Radeon ProRender for Blender  100%  
Installing to /home/myuser/.local/share/rprblender
Retrieving Blender version
...done
Checking HW configuration version
checkCompatibility_hardware begin...
> GetSystemInfo_ begin...
 + 1 0000:1f:00.0 vendor=1002 device=687f (Vega 10 XT [Radeon RX Vega 64])
> GetSystemInfo_ : libOpenCL.so can be loaded
 + 1 GPU supports OpenCL 2.000000
> GetSystemInfo_: SUCCESS.
> GetSystemInfo_ end...
checkCompatibility_hardware end...
checkCompatibility_driver begin...
grep: /var/opt/amdgpu-pro-local/doc: Is a directory
VideoController_DriverVersion = (AMD) 19.30
VideoController_Name = AMD Radeon RX Vega 64
checkCompatibility_driver : AMD driver compatible
checkCompatibility_driver end...
BuildRegistrationLink begin...
Register link = https://feedback.amd.com/se/5A1E27D23E8EC664?registrationid=5A1E27D259A3291C&appname=blender&appversion=2.82__sub_7___375c7dc4caf4&frversion=0.1061895&os=Linux5.0.0-37-generic&gfxcard=AMD_Radeon_RX_Vega_64&driverversion=19.30                                       
BuildRegistrationLink end...
...done
Checking os version
...done
Installing Radeon ProRender for Blender ...
Radeon ProRender for Blender EULA
Do you accept the agreement? (y or n)y
Installing Dependencies ...
dpkg-query: шаблону libgl1-amdgpu-mesa-dev не соответствует ни один пакет
Installing libgl1-amdgpu-mesa-dev ...
[sudo] пароль для myuser:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Будут установлены следующие дополнительные пакеты:
  libdrm-amdgpu-dev mesa-amdgpu-common-dev
Следующие НОВЫЕ пакеты будут установлены:
  libdrm-amdgpu-dev libgl1-amdgpu-mesa-dev mesa-amdgpu-common-dev
Обновлено 0 пакетов, установлено 3 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Необходимо скачать 0 B/686 kB архивов.
После данной операции объём занятого дискового пространства возрастёт на 4 861 kB.
Хотите продолжить? [Д/н] Д
Пол:1 file:/var/opt/amdgpu-pro-local ./ libdrm-amdgpu-dev 1:2.4.98-855429 [165 kB]
Пол:2 file:/var/opt/amdgpu-pro-local ./ mesa-amdgpu-common-dev 1:19.2.0-855429 [516 kB]
Пол:3 file:/var/opt/amdgpu-pro-local ./ libgl1-amdgpu-mesa-dev 1:19.2.0-855429 [5 156 B]
Выбор ранее не выбранного пакета libdrm-amdgpu-dev:amd64.
(Чтение базы данных … на данный момент установлено 394739 файлов и каталогов.)
Подготовка к распаковке …/libdrm-amdgpu-dev_2.4.98-855429_amd64.deb …
Распаковывается libdrm-amdgpu-dev:amd64 (1:2.4.98-855429) …
Выбор ранее не выбранного пакета mesa-amdgpu-common-dev.
Подготовка к распаковке …/mesa-amdgpu-common-dev_19.2.0-855429_amd64.deb …
Распаковывается mesa-amdgpu-common-dev (1:19.2.0-855429) …
Выбор ранее не выбранного пакета libgl1-amdgpu-mesa-dev.
Подготовка к распаковке …/libgl1-amdgpu-mesa-dev_19.2.0-855429_amd64.deb …
Распаковывается libgl1-amdgpu-mesa-dev (1:19.2.0-855429) …
Настраивается пакет libdrm-amdgpu-dev:amd64 (1:2.4.98-855429) …
Настраивается пакет mesa-amdgpu-common-dev (1:19.2.0-855429) …
Настраивается пакет libgl1-amdgpu-mesa-dev (1:19.2.0-855429) …

 

..installing libgl1-amdgpu-mesa-dev ok
..installing Dependencies ok
Installing Addon Files ...
..installing Addon Files ok
Trying to remove previously installed Blender addon...
...done
Installing addon to Blender ...
^CError:
 Traceback (most recent call last):
  File "./install.py", line 127, in install_component
    yield
  File "./install.py", line 325, in <module>
    subprocess.check_output(install_blender_addon_cmd, stderr=subprocess.PIPE)
  File "/usr/lib/python3.6/subprocess.py", line 356, in check_output
    **kwargs).stdout
  File "/usr/lib/python3.6/subprocess.py", line 425, in run
    stdout, stderr = process.communicate(input, timeout=timeout)
  File "/usr/lib/python3.6/subprocess.py", line 863, in communicate
    stdout, stderr = self._communicate(input, endtime, timeout)
  File "/usr/lib/python3.6/subprocess.py", line 1534, in _communicate
    ready = selector.select(timeout)
  File "/usr/lib/python3.6/selectors.py", line 376, in select
    fd_event_list = self._poll.poll(timeout)
KeyboardInterrupt

 

Installing 'addon to Blender' failed!
Signal caught, cleaning up

Outcomes