AnsweredAssumed Answered

Gigabyte Radeon AORUS RX 580 Doesn't work

Question asked by mathieuboon on Mar 20, 2020
Latest reply on Mar 23, 2020 by llvewire

Hello all,

 

I purchased a new Gigabyte Radeon AORUS RX 580 half a year ago,

It worked perfectly fine until last week, my screens went to black and the fans of the gpu started spinning like crazy.

When i rebooted the PC, the screens showed 'no signal'  and the fans immediately started going up to 100% again.

 

I reseated the GPU, all the cables etc etc, but nothing worked. so I returned it to the store.

I'm currently using my old GPU, and everything works fine.

 

Today I received an e-mail that they tested it and that it works properly, that none of the problems have been detected.

I'm really curious about what might have caused this, why does it work at the store but not in my PC?

 

My system:
Processor: AMD Ryzen 5 1600
Motherboard: ASRock AB350M Pro4
GPU: Gigabyte AORUS Radeon RX 580 8GB
RAM: HyperX Fury black HX424C15FB3/8
PSU: Corsair TX550M V2
Ssd: Crucial MX500 2,5" 250GB

 

I really hope someone can help me with this.

- Mathieu

Outcomes