AnsweredAssumed Answered

Reference Vega 56 bricked

Question asked by aithepotato on Mar 18, 2020
Latest reply on Mar 20, 2020 by neo5555

So I recently acquired a second hand reference model RX Vega 56 by PowerColor which worked perfectly fine, for some reason I won't be naming I flashed one of the 2 BIOS modes to a PowerColer Vega 64 for the unlocked HBM2 voltage, apparently the fan speed curve was also fully unlocked after that, many yays.

 

But after it working totally fine for almost half a year (Flashed it in December 2019), it finally "broke". I had some common crashes in a game that might have been to a new update, but I wanted to restart my pc and put the GPU back into the Vega 56 BIOS mode, rebooted and boom, GPU stopped giving display output and windows only recognized the VGA adapter, this BIOS is from all I know write protected, so I thought it wouldn't have been an issue with that, but I feel like somehow, between reboots, both BIOS's got corrupted one way or another, without any way of recovering it without a flashing card. 

 

I have tried reflashing the BIOS via Windows, (free)DOS and ArchLinux, all of them couldn't see the GPU, and after a few reboots, the GPUtach indicators stopped working and the fan stopped spinning, I thought it was officially dead as it wasn't even recognizing the VGA adapter anymore.

 

I tried doing a so called 1+8 pin method, without much success, and might have de-soldered a pin or 2 in the process without knowing for sure if it will ever work or not, any suggestions?

 

Thank you for reading by the way, this was a really long message.

Attachments

Outcomes